CasparCG Server hotfix releases for Flash Player end of life

Adobe Flash reaches EOL (End Of Life) by the end of 2020. To be able to use Flash templates in CasparCG Server after that deadline the following things need to be done.

  • Update Flash Player ActiveX (.ocx) to the most recent version. That is version 32.0.0.445 or above.
  • Update CasparCG Server to a version that corrects issue 1352.
  • Add a mms.cfg file to your Flash installation. This will keep Flash installed after the deadline and will let Flash player show CasparCG’s templates.

Update CasparCG Server

The following versions of CasparCG Server have all been patched to include the fix to allow them to run after the deadline.

Some steps are also needed to prepare your system in advance of the deadline that are outlined below.

Thanks to @silid for developing the fix and @didikunz for documenting the process and being a key member of chasing for these releases to be made!

Read the full text before proceeding and be aware of the Disclaimer below.

Update Flash Player

In Windows 10, let Windows Update install the Flash player. If you have anything blocking auto update, disable it and run “Search for Update”. Make sure, that the Flash update is listed and let Windows proceed.

In Windows 7 use Internet Explorer to download and install the most recent Flash Player ActiveX. Do that before the end of 2020. Adobe will disable the download pages after that date.

Add mms.cfg

This is the tricky, but most important part. You can either read through Adobe Administration Guide and create the files yourself or you can use the FlashCfgWriter.exe tool in this server zip files (make sure to Run As Administrator) or download it from GitHub

Screenshot

It has three buttons. The “Browse…” button let you browse to your CasparCG Server’s template folder, as this folder must be added to the allow-list of Flash Player. The “Write Config” button let you write the mms.cfg files to the folders where they belong. The “Check Version” button shows the version of the installed Flash Player ActiveX.

Disclaimer

Be aware, that if you add this mms.cfg files to your installation and NOT use a supported CasparCG Server build, Flash templates will not work anymore. So, if that applies to you, please only update Flash Player ActiveX, as this needs to be done asap, to make sure you do not miss it, before it gets unavailable.

6 Likes

Thanks for all these good works.
I am using mostly 2.1.0.3440 f15ba60 Beta 2. I think it is last version of 2.1. Please build a 2.1 version to include this fix.

The NRK version of 2.1 has been patched, and it is linked above.

The post has been updated to include a link for v2.3.1

2 Likes

2.1 never made it out of beta in the main repository, and so is considered abandoned. If you can it would be better for you to use the 2.1NRK version, as that is very similar but with some of the improvements from 2.2.
If you can’t use that for some reason then I can look building a new version of 2.1beta2 when I have a little spare time

1 Like

Please do.

@vimlesh1975 Have you tried using 2.1.12NRK which may not be an official release, but it is stable and is used in over 10 live shows per day…

Thank you @hummelstrand for recommending to test nrk version. So far it is working good.

@Julusian All version are working good for Flash EOL.
But Server version 2.0.7.1-flash eol template variables are not being listed with info template command.

I tested it, and you are right, it is not working. @Julusian or @silid: can you check, if the INFO TEMPLATE command uses the new URL syntax or if we need to add another path to the allowlist of Flash player, please?

EDIT: I disabled the allowlist and the problem persisted. So it seems to be broken somewhere else.

The INFO TEMPLATE command is the one that let a lot of users stay at the 2.0.7 version, to be able to query the variables from the template (for instance to use them inside a MOS system).

Hello everyone. Today flash has definitely stopped working. Although I had the updates disabled, Windows 10 did not allow the templates to run. A quick way to solve it has been to change the date to the servers and tell it that it is 2020. It has worked again.

We have a long tread names Flash End of Life that gives all the solutions that you don’t need to change the system date :slight_smile:

Thanks didikunz, we were waiting to change everything following the instructions, but we didn’t have time. Today they have stopped working and I have posted this solution in case it has happened to someone else. Many thanks for your work.

1 Like

Hi
The fix worked for me.
Had done nothing beforehand
Today I tried to run flash template from 2.3.0 didnt work
downloaded 2.3.1 and FlashCfgWriter.
copied config-files from 2.3.0 to 2.3.1
did run FlashCfgWriter as administrator, added my template folder, checked version (said “Everything well”) and wrote config.
started casparcg 2.3.1 and flash-templates did work.

Thanks. Good work.

br markus

2 Likes

Hello, any update on this? On other fixed server versions INFO TEMPLATE command is working, but not on 2.0.7.1. As a result some programs on my side don’t display text fields on this version.

Was wondering if there will be a fix.

The INFO TEMPLATE command is the one that let a lot of users stay at the 2.0.7 version, to be able to query the variables from the template (for instance to use them inside a MOS system).

I posted this issue 2 weeks ago here, but did not hear anything.

1 Like

It’s a shame because the ‘Info Template’ command is kind of critical to our workflow, so in the end we didn’t apply the patch and we’ll stay in Windows 1909 for a bit longer. We’ll consider changing if it gets a fix.

Did anybody try to apply the patch after the 12th of January or is that no longer an option at all?

Thank you

2 Likes

You can run the patch anytime, with any Flash.ocx version. As long as Windows does not uninstall it, it works anyway. The trick with that mms.cfg file helps to keep the ocx in place after EOL. But there is also a way to install (the latest) OCX files on new systems, described here.

1 Like

Hi guys.

I been trying to run flash templates for a couple of days in a new installation without success. I downloaded and tried 3 versions of casparCG: 2.0.7.1-flash-eol-hotfix, 2.1.12NRK and 2.3.1-lts-stable, also FlashInstaller.zip and FlashCfgWriter.zip. I followed step by step the guide and I can’t get it work. Also I searched in the log file if I found something and this what i got in 2.0.7, for example:
2.0.7

[2021-01-24 22:07:46.527] [6564] [info]    Flash 32.0.0.387
[2021-01-24 22:07:46.529] [6564] [info]    flash[cg20.fth.pal|0] Initialized.
[2021-01-24 22:07:46.529] [6564] [info]    flash[cg20.fth.pal|0] Invoking info-command: <invoke name="GetInfo" returntype="xml"><arguments></arguments></invoke>
[2021-01-24 22:07:46.564] [3280] [info]    flash-player[cg20.fth.pal|1024x576] Initialized.
[2021-01-24 22:07:46.564] [3280] [warning] flash-player[cg20.fth.pal|1024x576] Flash call failed:<invoke name="GetInfo" returntype="xml"><arguments></arguments></invoke>
[2021-01-24 22:07:46.608] [6564] [trace]   Template-Host Unknown

[2021-01-24 22:07:46.652] [6564] [info]    Initialized flash module.

[2021-01-24 22:07:46.696] [3280] [info]    flash-player[cg20.fth.pal|1024x576] Uninitialized.
[2021-01-24 22:07:46.699] [9948] [info]    flash[cg20.fth.pal|2439] Uninitialized.

[2021-01-24 22:07:59.544] [10448] [info]    Sent message to 127.0.0.1: 201 VERSION OK\r\n2.0.7.86498d14f Flash EOL Hotfix\r\n

[2021-01-24 22:08:15.288] [3788]  [info]    flash[cg20.fth.1080p5994|0] Initialized.
[2021-01-24 22:08:15.289] [3788]  [info]    flash[cg20.fth.1080p5994|0] Invoking add-command: <invoke name="Add" returntype="xml"><arguments><number>1</number><string>FRAME.ft</string><true/><string></string><string><![CDATA[ <templateData></templateData>]]></string></arguments></invoke>
[2021-01-24 22:08:15.326] [4164]  [info]    flash-player[cg20.fth.1080p5994|1920x1080] Initialized.
[2021-01-24 22:08:15.326] [4164]  [warning] flash-player[cg20.fth.1080p5994|1920x1080] Flash call failed:<invoke name="Add" returntype="xml"><arguments><number>1</number><string>FRAME.ft</string><true/><string></string><string><![CDATA[ <templateData></templateData>]]></string></arguments></invoke>

[2021-01-24 22:08:27.589] [4164]  [info]    flash-player[cg20.fth.1080p5994|1920x1080] Uninitialized.
[2021-01-24 22:08:27.593] [6564]  [info]    flash[cg20.fth.1080p5994|2439] Uninitialized.

Any suggestion ??

Tuto

Replace the flash .ocx manually. It’s still on an older version.

Privacy Policy   Terms of Service