Installing CasparCG-Server // Strange things will happen


#1

When i try to install CasparCG, i place the folder on “C:”

While starting the server, a message shows up that there is no config-file and now there will be one installed.
This new config-file is located directly at “C:” and NOT IN THE FOLDER. After changing and storing in the frontend, the values of the config-file on “C:” will be affected - not the one in the folder.

So i unwrapped the data out of the folder and copied it directly on “C:”. Now it works fine, but the problem is, that of course i cannot change manually anything in that config-file (it is located direktly on “C:”. Changes will only affect, if it is nested in a folder.

What happened here? Has anybody an idea, why CasparCG only accepts config-files directly on “C:” ?

[Working on Windows 10, CasparCG 2.0.7]


Setup with Decklink Duo 2
#2

Check the startup folder path in your desktop icon. Right click the icon and choose „Properties“. Set the path to the folder were Caspar is located.


#3

Hello Didi,

i just checked it . the path leads directly to the correct location where the folder is placed… But doesn´t work correctly.

Just to be safe; I have to place the frontend.exe into the same folder where the SERVER is? So the Frontend-Icon is in the same list, underneath the “casparcg.exe”, right?

I pulled a shortcut on the desktop, checked the path ich is directing to the folder

“C:\CasparCG Server 2.0.7\Server\casparcg_frontend.exe”

…and leads directly to the messagebox, that there was no config-file…


#4

Hm… Have you tried to run casparcg.exe directly? Does it give the same messagebox?


#5

This seems to be an issue that crops up every now and then.
eg Install casparcg

Perhaps it is a bug in the frontend that needs looking at?


#6

Directly it works fine.

Problem is, that i need to configure a DECKLINK DUO 2 to get Key&Fill out.

i am no programmer and i crawl hardly throu the lines in the config. Cecking oput this and that… but dont get out any proper video on the Decklink. The card is fine (checked with other PGM on the same machine.

As long i install the files of casper directly on C: it will work also with the frontend - BUT in this case i am not able to store any changes in that cnfig - file…


#7

To check, where did you download the casparcg_frontend.exe from?


#8

https://sourceforge.net/projects/casparcg/files/CasparCG_Frontend/CasparCG%20Frontend%202.0.7.zip/download


#9

Yeah, I get the issue with that version too. try this one instead, should work better https://download.guild.tv/casparcg/CasparCG_Server_207.exe
Ill see if we can get the link you used updated to a version without this issue


#10

WHEW!

I´ll check it tomorrow ( on job in a few minutes) - and will report asap!

THNXX very much!!


#11

I never had this issue with the config, working only in root? did you tried on another computer, with no card, just the standard config that comes with it, with the pal windows?

Decklink DUO connection drawing

and my Caspar.config for DUO2, Caspar Server 2.1 NRK RC1, 8-ch embedded audio (works also with 2.2)
my setting in the blackmagic config is 2x fill&key

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
    <media-path>E:\media</media-path>
    <log-path>E:\log/</log-path>
    <data-path>E:\data/</data-path>
    <template-path>E:\template</template-path>
    <thumbnail-path>E:\thumbnail/</thumbnail-path>
    <font-path>C:/Windows/fonts/</font-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  
  <mixer>
      <straight-alpha>false</straight-alpha>
  </mixer>

  <thumbnails>
         <generate-thumbnails>false</generate-thumbnails>
  </thumbnails>

<accelerator>auto</accelerator>

  <channels>
      <channel>
        <video-mode>1080i5000</video-mode>
        <straight-alpha-output>true</straight-alpha-output>
        <channel-layout>8ch</channel-layout>
          <consumers>
            <decklink>
              <device>1</device>
                <embedded-audio>true</embedded-audio>
                <channel-layout>8ch</channel-layout>
                <latency>low</latency>
                <keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
                <custom-allocator>true</custom-allocator>
            </decklink>
          </consumers>
      </channel>

      <channel>
        <video-mode>1080i5000</video-mode>
        <straight-alpha-output>true</straight-alpha-output>
        <channel-layout>8ch</channel-layout>
          <consumers>
            <decklink>
              <device>2</device>
                <embedded-audio>true</embedded-audio>
                <channel-layout>8ch</channel-layout>
                <latency>low</latency>
                <keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
                <custom-allocator>true</custom-allocator>
            </decklink>
          </consumers>
      </channel>
  </channels>

    <audio>
  	<channel-layouts>
  	  		<channel-layout name="8ch"         type="8ch"         num-channels="8" />
  	</channel-layouts>
    </audio>


  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
    <tcp>
      <port>3250</port>
      <protocol>LOG</protocol>
    </tcp>
  </controllers>
</configuration>