PLAY DECKLINK Input with different format not working 2.2+

So I have a machine with de HD extreme & a DUO 2
I have the output on the HD extreme on 1080p25, I have my a7sii on the DUO with 1080p50
In 2.0.7 and 2.1 I can just place it on a layer and start transforming it.

But from 2.2 upwards it does not work. It just sets the input to the output:

[info] Received message: PLAY 1-10 DECKLINK DEVICE 2 FORMAT 1080p5000\r\n
[info] DeckLink Duo 2 [2|1080p2500] Initialized
[info] Sent message PLAY OK\r\n

I also tried 2.3lts but still the same problem.

What does work is putting the HD extreme on 1080p50 and then routing the channel to the DUO (device 3) that is set on 1080p25. But that just gives extra stress on the system.

Am I doing something wrong or is it a limitation going forward?

Sounds to me like a new feature killing an old one. Can you please post a bug at Caspar’s GitHub page?

2.3 should respect a specified format, and should autodetect input format if none is specified.
2.2 has the limitation of only being able to work with the channel format

1 Like

Sorry for hijacking the thread but this reminded me about the INFO SYSTEM command. Is there any plan to bring back the DeckLink device list functionality? It’s been very useful for developing custom clients.

“2.2 has the limitation of only being able to work with the channel format”

Does it have something to do with the framerate producer mentioned in this thread: Is there a Server 2.1.x with updated CEF and Framerate producer?

I will try 2.3 again

Not really. There were some large changes in 2.2, and for some reason supporting inputs of other formats was dropped. Im not sure why.

Would be nice again, I have used it for things like a kisscam for 9:16 displays where a bit more latency was not a problem.
And sometimes you get something wierd and when you don’t have a Blackmagic Mini Coverter UpDownCross HD laying around this was always a dirty fix.

But like I said, adding a extra channel for the input format dan then routing the channel to a layer in the output format works as a super dirty fix.

Just found out the extra channel does not have to have a consumer.

<channel>
      <video-mode>1080p5000</video-mode>
      <consumers />
</channel>

Just works fine!

But when the channel does not exist it does not work, is there a way to add a channel while the server is running? Like the GRID view.

You could play a channel as input, that is not in the config in 2.0.7. That seems to be a breaking change. AFAIK there is no dynamic way to add a channel. You can only add or remove a consumer to an existing channel via AMCP commands.

In 2.3 the FORMAT parameter should work, if not then that is a recent bug that should be reported at github.

Adding channels on the fly is not supported. Its in the issue tracker, but there is no timeframe on it being done.

Privacy Policy   Terms of Service