[Newbie thread] About dynamic images loading to adobe flash


#1

I’ve followed the caspar tutorial, successfully load the dynamic image if the template has no animations (timeline)… but when it come to animations, in caspar server it showed this error,
no template queued on layer #…

I’ve tried to put a default source for the UILoader, when no parameters being passed, it load successfully…
when i pass the parameter, it shows the error above…
the parameter i tried to pass as below:
C:\Image\flag.png
file:///C:/Image/flag.png

the actionscript i used is following the tutorial…

package  {
	
	import flash.display.MovieClip;
	import se.svt.caspar.ICommunicationManager;
	import se.svt.caspar.IRegisteredDataSharer;
	import se.svt.caspar.template.CasparTemplate;
	
	
	public class PictoUILoader extends CasparTemplate {
		
		private const customParameterDescription:XML = 	
		<parameters>
			<parameter id="Pictohead_UI" type="string" info="File URL for Mascot" />
		</parameters>;
		
		override public function SetData(xmlData:XML):void {

			for each (var element:XML in xmlData.children())
		   	{
				if (element.@id == "Pictohead_UI")
			  	    Pictohead_UI.source = element.data.@value.toString();
			}
			
			super.SetData(xmlData);
		}
	}
	
}

Any help would be appreciated… thanks in advance!


#2

See this thread for a discussion about exactly the same issue


#3

thank you bro for your quick response! i’ll look into it ^^