Key/Fill over 2 DeckLInk Mini Monitors

Hello, thanks in advance for your help.

I have a setup with 2 x DeckLink Mini Monitors and am trying to get device 1 to output fill and device 2 to output key. I’m able to get everything set up correctly, and when I don’t “tie” the keyer together in config, it’s just slightly (but very noticeably) out of sync. Trying to get them sync’d up as much as possible, knowing that I don’t have the option for a reference.

I’ve tried the settings recommend by @didikunz in: A few questions about the Client … however I receive an error on initialization that I think is nulling out the ‘external_separate_device’ option.

Here’s my config as it relates to devices:


and here’s the output of CasperCG on startup:

[2019-11-08 17:22:54.407] [info]    Initializing OpenGL Device.
[2019-11-08 17:22:54.412] [info]    Initialized OpenGL 4.5.0 NVIDIA 398.11 NVIDIA Corporation
[2019-11-08 17:22:54.431] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2019-11-08 17:22:54.431] [info]    video_channel[1|1080p3000] Successfully Initialized.
[2019-11-08 17:22:54.464] [warning] Device does not support video-format: 1080p30
[2019-11-08 17:22:54.507] [info]    DeckLink Mini Monitor [1-1&&2|1080p3000] Disabled low-latency mode.
[2019-11-08 17:22:54.508] [info]    DeckLink Mini Monitor [1-1&&2|1080p3000] Disabled low-latency mode.
[2019-11-08 17:22:54.535] [info]    DeckLink Mini Monitor [1-1&&2|1080p3000] Initialized.
[2019-11-08 17:22:54.581] [info]    [decklink_consumer] Uninitialized.
[2019-11-08 17:22:54.641] [info]    DeckLink Mini Monitor [1-1&&2|1080p3000] Reference signal: not supported by hardware.
[2019-11-08 17:22:54.580] [error]   Exception: C:\Program Files (x86)\Jenkins\workspace\casparcg-server-dep\2.2.x\src\modules\decklink\consumer\decklink_consumer.cpp(376): Throw in function void __cdecl caspar::decklink::decklink_consumer::enable_video(enum _BMDDisplayMode)
[2019-11-08 17:22:54.580] [error]   Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::caspar_exception>
[2019-11-08 17:22:54.580] [error]   [struct caspar::tag_msg_info * __ptr64] = DeckLink Mini Monitor 4K [1-2|1080p3000] Could not enable fill video output.
[2019-11-08 17:22:54.580] [error]   [struct caspar::tag_stacktrace_info * __ptr64] =  0# 0x00007FF62F5998AE in casparcg
[2019-11-08 17:22:54.580] [error]    1# 0x00007FF62F5C8C50 in casparcg
[2019-11-08 17:22:54.580] [error]    2# 0x00007FF62F7BDDF3 in casparcg
[2019-11-08 17:22:54.580] [error]    3# 0x00007FF62F7B6961 in casparcg
[2019-11-08 17:22:54.580] [error]    4# 0x00007FF62F7B8A01 in casparcg
[2019-11-08 17:22:54.580] [error]    5# 0x00007FF62F602438 in casparcg
[2019-11-08 17:22:54.580] [error]    6# 0x00007FF62F67DF5F in casparcg
[2019-11-08 17:22:54.580] [error]    7# 0x00007FF62F67B0E0 in casparcg
[2019-11-08 17:22:54.580] [error]    8# 0x00007FF62F5945C9 in casparcg
[2019-11-08 17:22:54.580] [error]    9# o_strcat_s in ucrtbase
[2019-11-08 17:22:54.580] [error]   10# BaseThreadInitThunk in KERNEL32
[2019-11-08 17:22:54.580] [error]   11# RtlUserThreadStart in ntdll
[2019-11-08 17:22:54.580] [error]
[2019-11-08 17:22:54.580] [error]
[2019-11-08 17:22:54.580] [error]    0# 0x00007FF62F5998AE in casparcg
[2019-11-08 17:22:54.580] [error]    1# 0x00007FF62F5991DF in casparcg
[2019-11-08 17:22:54.580] [error]    2# 0x00007FF62FA3CDC7 in casparcg
[2019-11-08 17:22:54.580] [error]    3# _C_specific_handler in VCRUNTIME140
[2019-11-08 17:22:54.580] [error]    4# _TypeMatch in VCRUNTIME140
[2019-11-08 17:22:54.580] [error]    5# RtlCaptureContext in ntdll
[2019-11-08 17:22:54.580] [error]    6# 0x00007FF62F5C67BF in casparcg
[2019-11-08 17:22:54.580] [error]    7# 0x00007FF62F5C8D12 in casparcg
[2019-11-08 17:22:54.580] [error]    8# 0x00007FF62F59CDB3 in casparcg
[2019-11-08 17:22:54.580] [error]    9# 0x00007FF62F5A077C in casparcg
[2019-11-08 17:22:54.580] [error]   10# 0x00007FF62F98C638 in casparcg
[2019-11-08 17:22:54.580] [error]   11# BaseThreadInitThunk in KERNEL32
[2019-11-08 17:22:54.580] [error]   12# RtlUserThreadStart in ntdll
[2019-11-08 17:22:54.580] [error]
[2019-11-08 17:22:54.694] [info]    Initialized channels.
[2019-11-08 17:22:54.695] [info]    Initialized controllers.
[2019-11-08 17:22:54.695] [info]    Initialized osc.

Your input/help is greatly appreciated. Thank you

casparCG does not have support of Decklink Mini Monitor See link Supported Decklinks

I don’t think this is correct. It’s not listed there, but it should work anyway. Concerning the setup:

You can probably try, if tit is enough, when you get rid of the second cards definition. I have never tried the separate key, so I have no experience., but probably that will do:


I have been using a mini-monitor in my dev setup for years without issue.
In reality, I expect all modern decklinks (anything pcie based) to work fine

can you share your config? because I cant get it work.

[decklink_consumer] Uninitialized.
[2020-06-15 15:54:58.220] [error]   Exception: d:\projects\server-master\casparcg-server-master\src\modules\decklink\consumer\../util/util.h(244): Throw in function class ATL::CComPtr<struct IDeckLink> __cdecl caspar::decklink::get_device(unsigned __int64)
[2020-06-15 15:54:58.220] [error]   Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::user_error>
[2020-06-15 15:54:58.220] [error]   [struct caspar::tag_msg_info * __ptr64] = Decklink device 1 not found.

my config is this:


It seems, that it does not find the Decklink card. Did you installed the driver? Can you see the control panel applet?