Decklink Duo 2 Playout/Rec and Key/Fill - help!

well, check also the cable, try to swap, sometimes happens

you could try with just this channel in config, this works for me

        <channel>
            <video-mode>1080i5000</video-mode>
            <consumers>
            <decklink>
                <device>1</device>
                <embedded-audio>true</embedded-audio>
                <latency>normal</latency>
                <keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
            </decklink>
                <system-audio />
            </consumers>
        </channel>

Hi
this is how I usually have my channels configured

<channels>
  	<channel>
		<video-mode>1080i5000</video-mode>
		<straight-alpha-output>false</straight-alpha-output>
		<consumers>
			<decklink>
				<device>2</device>
				<embedded-audio>true</embedded-audio>
				<channel-layout>stereo</channel-layout>
				<latency>normal</latency>
				<keyer>external</keyer>
				<key-only>false</key-only>
				<buffer-depth>3</buffer-depth>
				<custom-allocator>true</custom-allocator>
			</decklink>  
		</consumers>
	</channel>
	<channel>
		<video-mode>1080i5000</video-mode>
		<straight-alpha-output>false</straight-alpha-output>
		<consumers>
			<decklink>
				<device>3</device>
				<embedded-audio>true</embedded-audio>
				<channel-layout>stereo</channel-layout>
				<latency>normal</latency>
				<keyer>default</keyer>
				<key-only>false</key-only>
				<buffer-depth>3</buffer-depth>
				<custom-allocator>true</custom-allocator>
			</decklink>
		</consumers>
	</channel>
</channels>

AND Decklink configured as
1 - connector SDI 1
2 - connector SDI 3 & SDI 4
3 - connector SDI 2
4 - connector none

this gives me the following CasparCG output
logic BNC from motherboard ref - 1 - 3 - 2 - 4
Channel 1 GRAPHICS connector 2 (key) connector 4 (fill)
Channel 2 PLAYOUT (just FILL) connector 3
and connector 1 is free as a record/input-channel

Configuration is a pain but the result is logical
first BNC is INPUT and DEVICE 1 if yor using the SVT client and “Decklink Input”
second BNC is Playout channel (ch2 in CasparCG)
third and forth BNC are Graphics (key&fill) and channel 1 in CasparCG

If the order of the CasparCG-channels are not working for you then just copy paste the channels in suitable order in the config-file.

br markus

No it has not, You can mix any config as you like. I have 3 of these…

at least I had to do somethinng extra with the 8K to get it to work with vMix (there was som tutorial about that on the vmix-pages)

Yes, in @TCH 's config, there is still one channel too much, there should only 2 decklink channels configured. It seems, that the 3rd overwrites the key channel of the fill & key channel.

Understand that for CasparCG a channel with a fill and a key is still only one channel, that happens to use two BNC connectors. So the config of @markusnygard is closer to the truth than yours.

to me is really strange that the key-sdi is all black but somehow the lower third has transparency, even if it is weird.
Happened to me once when one sdi connector was malfunctioning and the technician tried to tune something, producing a similar weird transparency.
Probably he was trying to cut blacks or something, a really terrible technician by the way, finally another guy found the issue.

Thank you, I wasn’t sure about it, good to know

That looks like so, when the rate parameter has been turned or so. We had that many times when something was wrongly configured, or the key input to the mixer was not routed to the Key Source.

1 Like

Thanks for your help everyone, I wanted to reply on Friday but was unable to due to the new user post limit. I’ve tried dropping in @markusnygard 's script into the config and changing the settings for the connectors, I can now see fill and key in their respective channels but I’m a bit confused at to how I should configure the settings within Caspar. If I’ve got the graphics set to CH1 in then it doesn’t overlay them on PGM, I can just see them in their own channels. If I change it to CH2 then it will overlay them on the VT, but only the VT - if I cut to a camera then they’re gone.
Also, should the Decklink input settings be CH1 Device 1 or CH2 Device 1?

Thanks so much

I seems, that you don’t know what a downstream keyer is and how to set it up. On your ATEM you can configure two inputs going to the DSK (downstream keyer) to be able to add it on top of the program. I already posted you the link how to configure that. So in the end there is a button on the mixer, usually on the right side of the panel that says “DSK” if you activate it, you can see the graphic added to the program.

Ah yes, thank you! I had set it up as per that link you posted before but the Key & Fill sources in the dropdown must’ve reverted to default when I unplugged the SDIs from the back of the ATEM to test the cables. It works!

In terms of getting the PGM out from the desk back into Caspar via the decklink input, do you know how this should to be set? I’ve tried with the settings above but it does strange things, the Key channel goes completely white and the PGM output seems to get sent to the Fill channel. Should it be CH2 Device 1?

The think is, I have not enough informations to point out, what you do wrong. as I would need to know what ATEM, which Decklink out goes to which ATEM input etc. First you need to get the DSK to work, after that we can look at the rest.

Ok, great. So I’ve currently got PGM out via SDI going into connector 2, and Caspar output via SDI from connector 3 going into input 5 on the ATEM 2 M/E Production Studio 4K. Then I have Key and Fill on connectors 4 and 5 going into 7 and 8 on the ATEM. Key and Fill and the DSK seem to be working ok now and I can seem them in the PGM. I can also see VT playout in the correct channel.

There seems to be a mees on the Decklink side. As I asume, that you count bottom up it sounds, like you send the PGM to the DSK Key…

The Decklinks have a bit weird assignment of the BNC connectors. On mine I would do it like so, but maybe 3 & 4 could also be the other way around…

Hmm, ok, I’m a bit confused now. I just copied out the config and card settings that @markusnygard had posted. So if I understand correctly, would I change the card settings back to default? Like this?
Connector 1 - SDI 1 & 2
Connector 2 - SDI 3
Connector 3 - None
Connector 4 - SDI 4

I assume I’d need to change the Caspar config too?

You still have not understood the difference between connectors and channels! A connector is a physical BNC connector. A channel is what Caspar uses to output video. A channel can have 1 or 2 (or even 0) BNC connectors attached to it. So I think you should not change anything but connecting the right cables to the right connectors. Maybe you take a SDI-Monitor and a BNC cable and go trough all BNC’s of the Decklink to figure out, what is what. Then, when you know that, connect the BNC’s of the Decklink to the correct BNC’s on the ATEM. Should be straight forward.

Sorry, I have a background as a camera operator and all of this mixer and server stuff is totally new to me. I know where everything is plugged into and where it’s going, all my cables are labeled and I have run them into the back of a PVM completely independent of Caspar to verify what they are. I’m just trying to follow what people have been telling me on here.

But you still have it not working, correct? Then something must be wrong. Can you post your current casparcg.config again, and a screenshot of your BMD controllpanel applet (the “Connections” tab visible). We should finally come to a solution.

Ok, thanks for your patience. Here is the config and shots of the BMD control.

IMG_6379
IMG_6380
IMG_6381
IMG_6382

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <log-level>info</log-level>
  <paths>
    <media-path>T:\</media-path>
    <log-path>log/</log-path>
    <data-path>data/</data-path>
    <font-path>font/</font-path>
    <template-path>template/</template-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
  	<channel>
		<video-mode>1080i5000</video-mode>
		<straight-alpha-output>false</straight-alpha-output>
		<consumers>
			<decklink>
				<device>2</device>
				<embedded-audio>true</embedded-audio>
				<channel-layout>stereo</channel-layout>
				<latency>normal</latency>
				<keyer>external</keyer>
				<key-only>false</key-only>
				<buffer-depth>3</buffer-depth>
				<custom-allocator>true</custom-allocator>
			</decklink>  
		</consumers>
	</channel>
	<channel>
		<video-mode>1080i5000</video-mode>
		<straight-alpha-output>false</straight-alpha-output>
		<consumers>
			<decklink>
				<device>3</device>
				<embedded-audio>true</embedded-audio>
				<channel-layout>stereo</channel-layout>
				<latency>normal</latency>
				<keyer>default</keyer>
				<key-only>false</key-only>
				<buffer-depth>3</buffer-depth>
				<custom-allocator>true</custom-allocator>
			</decklink>
		</consumers>
	</channel>
</channels>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>localhost</host>
      <port>8000</port>
    </media-server>
  </amcp>
  <flash>
    <buffer-depth>auto</buffer-depth>
    <enabled>false</enabled>
  </flash>
  <html>
    <remote-debugging-port>0</remote-debugging-port>
    <enable-gpu>true</enable-gpu>
  </html>
  <ffmpeg>
    <producer>
      <auto-deinterlace>interlaced</auto-deinterlace>
      <threads>4</threads>
    </producer>
  </ffmpeg>
  <ndi>
    <auto-load>false</auto-load>
  </ndi>
  <osc>
    <default-port>6250</default-port>
    <disable-send-to-amcp-clients>false</disable-send-to-amcp-clients>
    <predefined-clients />
  </osc>
</configuration>

This is the cable setup out of the back of the Duo 2:

PGM from ATEM going into connector 1
VT Out going from connector 2
Key in 3
Fill in 4

I can see the output from the card correctly, both for the VT and for the graphics. Have tested the PGM SDI out of the ATEM and can see it on a PVM.
IMG_6378
IMG_6384

So what is not working now? The input?

Privacy Policy   Terms of Service