Decklink Duo 2 Playout/Rec and Key/Fill - help!

Hi all, so we’ve just moved from using a Decklink Duo to a Duo 2 as we needed DSK plus record and playout capability. Our current config appears to work for record and playout, but I can’t get the key and fill to look right. We’re using an ATEM 2 M/E Production Studio 4K. This is our current config:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <log-level>info</log-level>
  <paths>
    <media-path>T:\</media-path>
    <log-path>log/</log-path>
    <data-path>data/</data-path>
    <font-path>font/</font-path>
    <template-path>template/</template-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
      <video-mode>1080i5000</video-mode>
      <consumers>
        <decklink>
          <device>1</device>
          <key-device>2</key-device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>external</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5000</video-mode>
      <consumers>
        <decklink>
          <device>2</device>
          <key-device>2</key-device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>default</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>720p5000</video-mode>
      <consumers>
        <screen>
          <device>1</device>
          <aspect-ratio>default</aspect-ratio>
          <stretch>fill</stretch>
          <windowed>true</windowed>
          <key-only>false</key-only>
          <vsync>false</vsync>
          <borderless>false</borderless>
          <interactive>true</interactive>
          <always-on-top>false</always-on-top>
          <x>0</x>
          <y>0</y>
          <width>0</width>
          <height>0</height>
          <sbs-key>false</sbs-key>
          <colour-space>RGB</colour-space>
        </screen>
        <system-audio>
          <channel-layout>stereo</channel-layout>
          <latency>200</latency>
        </system-audio>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5000</video-mode>
      <consumers>
        <decklink>
          <device>4</device>
          <key-device>4</key-device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>default</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>localhost</host>
      <port>8000</port>
    </media-server>
  </amcp>
  <flash>
    <buffer-depth>auto</buffer-depth>
    <enabled>false</enabled>
  </flash>
  <html>
    <remote-debugging-port>0</remote-debugging-port>
    <enable-gpu>true</enable-gpu>
  </html>
  <ffmpeg>
    <producer>
      <auto-deinterlace>interlaced</auto-deinterlace>
      <threads>4</threads>
    </producer>
  </ffmpeg>
  <ndi>
    <auto-load>false</auto-load>
  </ndi>
  <osc>
    <default-port>6250</default-port>
    <disable-send-to-amcp-clients>false</disable-send-to-amcp-clients>
    <predefined-clients />
  </osc>
</configuration>```

Which seems to work in this way:

Main Playout is Channel 4 - Device 4
PGM in from ATEM in is Channel 3
Record on Channel 3
DSK is Channel 2

We do seem to get lower thirds pulled through on CH2 but they don't look right. Any advice or help would be much appreciated!

you have key-device set to 2 for both channel, I’m not sure if this is your problem, but in my setup I just skipped that entry leaving only

in my case is 2fill + 2 keys

here my config for the second channel

        <channel>
            <video-mode>1080i5000</video-mode>
            <consumers>
            <decklink>
                <device>2</device>
                <embedded-audio>true</embedded-audio>
                <latency>normal</latency>
                <keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
            </decklink>
                <system-audio />
            </consumers>
        </channel>

There are a few things:

  • Get rid of all <key-device> lines. I don’t know, if they mess things up, but they are only used for external_separate_device mode and so they can be deleted.
  • I asume, that channel (device) 2 is the playout channel, but what is device 4 used for? Usually you do not add a channel to the config, when you want to use it for recording.
  • Please check if you have set the decklink settings correctly for the fill/key configuration.

EDIT: @Andrea and I posted at the same time, so some stuff is double.

1 Like

Thanks both. Bit of a n00b question but do I need to close Caspar when I edit the config file?

You need to, it only reads it on startup… :slight_smile:

Thanks! I’ll have a go now. To answer your earlier question, the main playout seems to be on CH4, I don’t know if this is the best way to do it.

This is the card setup (excuse the non-screen grab):

Hi all, so that didn’t seem to work - the graphic looks absolutely fine in the Fill channel, it just seems to be when the Key is on it looks totally off. I’m just using the demo lower third from Loopic so I know that there is no transparency, but as soon as I hit the DSK on the ATEM it doesn’t look correct.

How it should look:

How it looks with DSK on:

Is the Alpha channel getting messed up somewhere?

Have you checked this guide. scroll down until you reach the ATEM settings. The picture looks like you did not configure the key settings correctly. To be sure, that a valid key is coming out of Caspar: How does it look, when you only show the key channel?

Thanks, just had a look at the link and the settings on the ATEM look the same as that document. The Key channel doesn’t seem to show anything at all

what looks like the alfa channel on a black screen?
in the same way as you did for the fill

the picture looks strange, like you are putting the same fill on the key channel
or some kind of chroma key

The order of the SDI connectors is not very logical, so I would try going trough all of them and see where the key is coming out…

And that setting SDI 1 & 2 is very important (see my screenshot).

The alpha on black is just black, I don’t see anything at all. I see what you mean about the chroma key, it does kind of look like that.

the alpha channel should be white or grayscale in the same position as the fill,
basically you should see on the alpha channel a black and white version of the fill channel [sort of]

So the card is currently set to:
1 - SDI 1&2
2 - SDI 3
3 - None
4 - SDI 4

Do I need to change anything in Caspar to make one of the channels Key/Fill?

Hmm, no, I definitely don’t see that. It’s just a black screen:

mmm, strange
I wonder what does the item to show in transparency

did you make any changes to the config file?
if yes can you please post it again

you should have defined 3 channel entries
as the key is taken automatically

Here is the current config file - I took out the key-device entries. Thanks for all your help so far, likewise @didikunz!

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <log-level>info</log-level>
  <paths>
    <media-path>T:\</media-path>
    <log-path>log/</log-path>
    <data-path>data/</data-path>
    <font-path>font/</font-path>
    <template-path>template/</template-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
      <video-mode>1080i5000</video-mode>
      <consumers>
        <decklink>
          <device>1</device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>external</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5000</video-mode>
      <consumers>
        <decklink>
          <device>2</device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>default</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>720p5000</video-mode>
      <consumers>
        <screen>
          <device>1</device>
          <aspect-ratio>default</aspect-ratio>
          <stretch>fill</stretch>
          <windowed>true</windowed>
          <key-only>false</key-only>
          <vsync>false</vsync>
          <borderless>false</borderless>
          <interactive>true</interactive>
          <always-on-top>false</always-on-top>
          <x>0</x>
          <y>0</y>
          <width>0</width>
          <height>0</height>
          <sbs-key>false</sbs-key>
          <colour-space>RGB</colour-space>
        </screen>
        <system-audio>
          <channel-layout>stereo</channel-layout>
          <latency>200</latency>
        </system-audio>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5000</video-mode>
      <consumers>
        <decklink>
          <device>4</device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>default</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>localhost</host>
      <port>8000</port>
    </media-server>
  </amcp>
  <flash>
    <buffer-depth>auto</buffer-depth>
    <enabled>false</enabled>
  </flash>
  <html>
    <remote-debugging-port>0</remote-debugging-port>
    <enable-gpu>true</enable-gpu>
  </html>
  <ffmpeg>
    <producer>
      <auto-deinterlace>interlaced</auto-deinterlace>
      <threads>4</threads>
    </producer>
  </ffmpeg>
  <ndi>
    <auto-load>false</auto-load>
  </ndi>
  <osc>
    <default-port>6250</default-port>
    <disable-send-to-amcp-clients>false</disable-send-to-amcp-clients>
    <predefined-clients />
  </osc>
</configuration>```

Seems all correct at first look
I wonder if the duo 2 has the same limitation as the 8k Pro

make a backup copy of the config file and try only with one channel
the fill+key one
get rid of all the others

if still no key, you could try to set decklink to 1&2 and 3&4,
like for double fill+key

then if it finally works try to add the other channels one at time to see when the issue reappear

Thanks, I’ll give it go. I didn’t set up the original config so I’m a bit confused myself. Everything seems to work otherwise, it’s just that the DSK doesn’t look right

Privacy Policy   Terms of Service