Catching NDI from NDI bridge tools

We are trying to get a NDI from NDI tools brdge. If we use the NDI monitor it appears 3 parts.
NDI Bridge name ( Computer on other side of the bridge ( NDI NAME ))

We used normal NDI on CasparCG using:
Play 1-10 "ndi://[Computername]/[NDI Stream name]"

With NDI Bridge we had tried:
Play 1-10 "ndi://[Bridge Name]/[Computername]/[NDI Stream name]"

But it didn’t work. We tried a lot of ways and none of them worked.
Anyone managed to get a stream from NDI Bridge working?

Have you tried routing it through a studio monitor output?

I tried routing with ZEN RTx Receiver / Transmitter and it worked. I just wanted to get the streaming directly without applications in the middle.
Do not know if this is possible with 2.3.3 version of CasparCG.

I run similar tests recently and encountered similar problems

There is a second mechanism to pass the NDI address to Caspar. It bypasses the expression processing used when the address starts with ndi://, passing the source addresss direct to the NDI producer. The relevant expression parsing code can be viewed in the Github CasparCG server version 2.3 file /src/modules/newtek/producer/newtek_ndi_producer.cpp starting at line 266.

Run the command ndi list on the CasparCG server console. When I run this on my testbed system one of the listed sources is “ANDYS-IMAC.FRITZ.BOX (NDI Signal Generator)”. I can play this on channel 1 layer 10 with the command:

play 1-10 "[NDI]" "ANDYS-IMAC.FRITZ.BOX (NDI Signal Generator)"

If the NDI LIST command shows the output from your NDI Bridge in the list, try the above command form using the bridge source address reported in the list.

Andy

UPDATE
I have completed some tests using the NDI tools bridge in local mode as I lack the infrastructure for interconnected networks. Apologies for the long and unimaginative names here.
Bridge name: andys-nuc-bridge
Computer name: andys-imac.fritz.box
Signal name: ndi signal generator

Caspar server version 2.3.3_LTS displays the test signal source when I use either of the two commands below:

play 1-10 "ndi://andys-nuc-bridge+(andys-imac.fritz.box/ndi signal generator)"
play 1-10 "[ndi]" "andys-nuc-bridge (andys-imac.fritz.box (ndi signal generator))"

The parser for the first version starting ndi:// replaces the + in the string by a space character. The status report in the casparcg server text display includes an [info] report that shows the name string has been converted to andys-nuc-bridge (andys-imac.fritz.box (ndi signal generator))

3 Likes

Thanks @andyw, I can confirm that works with

play 1-10 “ndi://andys-nuc-bridge+(andys-imac.fritz.box/ndi signal generator)”

Didn’t managed to make it work with play 1-10 “[ndi]” "…

Thanks again

@Gaspar, pleased to hear you can receive signals from the NDI bridge.

I want to add the bridge address source process to my GitHub “Introduction to CasparCG” document, but only when I’m sure of the process, and that both address methods operate as expected. I can get the ndi:// method to fail when I use a “+” as part of the bridge name. I expect this because the NDI address processing code in the server replaces “+” by " ". I can get the address with the + to work in a play 1-10 [ndi] “…” request.

When I use the “ndi://andys-nuc-bridge+(andys-imac…” or “ndi://andys-nuc-bridge (andys-imac…” form of source address both correctly receive the source and display it in the assigned channel and layer. When I type the ndi:// style of address the server log shows a message of the form:

[info]  ndi[4|andys-nuc-bridge (andys-imac.fritz.box (ndi signal generator))] Source currently not available

A few seconds later the display of the source starts up. The number after the ndi[ updates after a stop and start of the ndi source. When I enter the text between the | and the ] into a a command

play 1-10 [ndi] "andys-nuc-bridge (andys-imac.fritz.box (ndi signal generator))"

this adressing mode also works. If you get a chance, could I request you try using the ndi:// method then look at the server log and try the reported address layout via the play 1-10 [ndi] “…” address style, and let the community know if that [ndi] style address worked for you?

Andy

Privacy Policy   Terms of Service