Ndi source as input

Add quotes to the input path if it has any spaces.

PLAY 1-1 "ndi://ITL/Test Pattern"
1 Like

Or, if that doesn’t work either, try:

PLAY 1-1 [NDI] "ITL (Test Pattern)"

maybe Your sever version was 2.2.0,I had the same problem in 2.2.0 ,then I tried 2.3.0,it’s woked fine.

Hi
Is the input path the same that NDIAnalysis give if you write “NDIAnalysis.exe /find”

I use the ndi studio monitor to identify the name of the ndi source,
the example amcp protocol to add a ndi source is:PLAY 1-1 "ndi://ITL/Test Pattern"
don’t forget thequote. Then,you can see the picture below, substitute the ITL with “LIVEPC”and the Test Pattern with “NVIDIA…”

1 Like

I am getting below error, any please helo

Received message from 127.0.0.1: PLAY 1-1"ndi://DESKTOP-DNIP730/vMix - Output 3"\r\n
[2022-01-29 23:33:51.961] [10912] [error]   producer\input\input.cpp(279): Throw in function caspar::ffmpeg::`anonymous-namespace'::<lambda9>::operator ()
Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::ffmpeg::averror_protocol_not_found>
std::exception::what: Unknown exception
[struct boost::errinfo_api_function_ *] = avformat_open_input(&weak_context, narrow(resource_name).c_str(), nullptr, &format_options)
1330794744, "Unknown error"[struct caspar::tag_msg_info *] = Protocol not found
[struct caspar::tag_source_info *] = ndi://DESKTOP-DNIP730/vMix - Output 3

[2022-01-29 23:33:51.976] [10912] [error]   File not found. No match found for parameters. Check syntax:ndi://DESKTOP-DNIP730/vMix - Output 3
[2022-01-29 23:33:51.979] [10912] [warning] Failed to execute command: PlayCommand on AMCPCommandQueue Channel 1 for TCP Port 5250
[2022-01-29 23:33:51.984] [10912] [info]    Sent message to 127.0.0.1: 501 PLAY FAILED\r\n

Looks like you are running an older version.

I have CasparCg Srver 2.0.7 & Client 2.0.8 which is latest - is that I need same server / client version?
Secondly, the NDI source is running from another pc not from the same machine where CasparCG is installed I can see the source is working fine in NDI monitor.

Server 2.0.7 does not support NDI input. Please try 2.2 or 2.3

video layer showing in my Casparcg client is 10, should I use STOP 10-1 and same as in the case Play 10-1? (I am unable to change video layer in custom command)
having below error

[2022-01-30 16:44:32.677] [error]    Turn on log level debug for stacktrace.
[2022-01-30 16:44:32.677] [info]    Sent message to 127.0.0.1:404 PLAY FAILED\r\n
[2022-01-30 16:45:00.098] [info]    Received message from 127.0.0.1: PLAY 1-10 "TESTPATTERNS/1080_TEST" CUT 0 Linear RIGHT\r\n
[2022-01-30 16:45:00.099] [error]    Turn on log level debug for stacktrace.
[2022-01-30 16:45:00.100] [info]    Sent message to 127.0.0.1:404 PLAY FAILED\r\n
[2022-01-30 16:46:43.162] [info]    Received message from 127.0.0.1: PLAY 1-1 "ndi://DESKTOP-DNIP730/vMix Output - 3"\r\n
[2022-01-30 16:46:43.166] [info]    Loaded "C:\Program Files\NDI\NDI 5 Tools\Runtime\Processing.NDI.Lib.x64.dll"
[2022-01-30 16:46:43.185] [info]    ndi[0|DESKTOP-DNIP730 (vMix Output - 3)] Source currently not available.
[2022-01-30 16:46:43.190] [info]    Sent message to 127.0.0.1:202 PLAY OK\r\n

Its CHANNEL-LAYER so 1-10 (your log output shows PLAY 1-1 though)

still nothing happens, don’t know what is going wrong as the console didn’t give me any error

Type NDI LIST in Caspars console window and see, if the source is present, and how the actual spelling needs to be.

NDI LIST shows complete set of NDI sources available, but when I want to play it said source currently not available, meanwhile the same source is playing well in vMix & Wirecast (logs below)

#200 NDI LIST OK
1 "DESKTOP-8TOBN3H (InstaPlayout NDI Renderer (2))" 10.39.1.132:5962
2 "DESKTOP-8TOBN3H (InstaPlayout NDI Renderer)" 10.39.1.132:5961
3 "DESKTOP-8TOBN3H (Wirecast Live Output)" 10.39.1.132:5963
4 "DESKTOP-DNIP73O (vMix - Output 3)" 10.39.1.77:5961
5 "DESKTOP-DNIP73O (vMix - Output 4)" 10.39.1.77:5962
6 "DESKTOP-UPHA33L (Remote Connection 1)" ndi-app:DESKTOP-UPHA33L%20(Remote%20Connection%201)
7 "DESKTOP-UPHA33L (vMix - Output 1)" 10.39.1.72:5962
8 "UAE-BACKUPSERVER-NEW (Wirecast Live Output)" 10.39.1.125:5961

[2022-01-31 16:10:01.717] [error]   Failed to connect to media-scanner. Is it running?
[2022-01-31 16:10:01.717] [error]   Reason: Connection refused
[2022-01-31 16:10:01.717] [info]    Sent message to 127.0.0.1:501 TLS FAILED\r\n
[2022-01-31 16:10:01.717] [info]    Sent message to 127.0.0.1:200 DATA LIST OK\r\n\r\n
[2022-01-31 16:10:05.722] [error]   Failed to connect to media-scanner. Is it running?
[2022-01-31 16:10:05.722] [error]   Reason: Connection refused
[2022-01-31 16:10:05.722] [info]    Sent message to 127.0.0.1:501 THUMBNAIL LIST FAILED\r\n
[2022-01-31 16:12:22.886] [info]    Received message from 127.0.0.1: PLAY 1-10 "ndi://DESKTOP-DNIP730/vMix - Output 4"\r\n
[2022-01-31 16:12:22.888] [info]    ndi[0|DESKTOP-DNIP730 (vMix - Output 4)] Source currently not available.
[2022-01-31 16:12:22.891] [info]    Sent message to 127.0.0.1:202 PLAY OK\r\n

Is the media scanner running? If yes you have some firewall issue, that probably also stops NDI.

media scanner is running

1 "DESKTOP-DNIP73O (vMix - Output 3)" 10.39.1.77:5961
2 "DESKTOP-DNIP73O (vMix - Output 4)" 10.39.1.77:5962
3 "DESKTOP-UPHA33L (Remote Connection 1)" ndi-app:DESKTOP-UPHA33L%20(Remote%20Connection%201)
4 "DESKTOP-UPHA33L (vMix - Output 1)" 10.39.1.72:5962
5 "UAE-BACKUPSERVER-NEW (Wirecast Live Output)" 10.39.1.125:5961

[2022-02-01 15:10:56.871] [info]    Received message from 127.0.0.1: PLAY 1-10 "ndi://DESKTOP-DNIP73O (vMix - Output 3)"\r\n
[2022-02-01 15:10:56.871] [error]    Turn on log level debug for stacktrace.
[2022-02-01 15:10:56.871] [info]    Sent message to 127.0.0.1:404 PLAY FAILED\r\n
[2022-02-01 15:11:32.879] [info]    Received message from 127.0.0.1: PLAY 1-10 "ndi://DESKTOP-DNIP73O/(vMix - Output 3"\r\n
[2022-02-01 15:11:32.881] [info]    ndi[0|DESKTOP-DNIP73O ((vMix - Output 3)] Source currently not available.
[2022-02-01 15:11:32.883] [info]    Sent message to 127.0.0.1:202 PLAY OK\r\n

On the second command you missed the last bracket. Does that makes a difference?

tried with / without brackets, same issue nothing happens, any idea?

The name reported by the NDI LIST command needs to be sighly modified when used in the play command. it needs a "ndi://computer_name/source_name" format of URL. Using your eample of “DESKTOP-DNIP730 (vMix - Output 3)” as the example here, the computer_name is “DESKTOP-DNIP730” and the source_ name is the part in brackets but without the brackets. Try the command:

PLAY 1-10 "ndi://DESKTOP-DNIP730/vMix - Output 3"

I assume the output from vMix is using the same scan standard as the CasparCG channel you are using to play the source. CasparCG only supports the standard scan formats so sending a 1300 x 800 signal will not show the signal, whilst it may be shown by the NDI Video Monitor Tool.

When I play an NDI source off a computer on my network I initally see the “source currently not available” message in the log, but the NDI source is displayed a few seconds later once the NDI negotiations about format and quality have completed.

1 Like

I’ve been testing NDI Bridge lately, to deal with NDI outside your local network. I think that means that there is an extra step in the address (Group + computer_name + source_name), it should be just an extra slash, right? I cannot seem to find the way to make it work, and I wonder if it’s a server limitation.

#200 NDI LIST OK
1 "MOUNTAIN (Remote Connection 1)" ndi-app:MOUNTAIN%20(Remote%20Connection%201)
2 "TEST (LAPTOP-KDN2J54S (Remote Connection 1))" 192.168.0.183:5963
3 "TEST (LAPTOP-KDN2J54S (Rotulos))" 192.168.0.183:5964

play 1-10 ndi://TEST/LAPTOP-KDN2J54S/Rotulos"
[2022-04-07 18:41:10.990] [info]    Received message from Console: play 1-10 ndi://TEST/LAPTOP-KDN2J54S/Rotulos"\r\n
#202 PLAY OK
[2022-04-07 18:41:10.990] [info]    ndi[1|TEST (LAPTOP-KDN2J54S)] Source currently not available.
play 1-10 ndi://LAPTOP-KDN2J54S/Rotulos/"
[2022-04-07 18:41:35.847] [info]    Received message from Console: play 1-10 ndi://LAPTOP-KDN2J54S/Rotulos/"\r\n
#202 PLAY OK
[2022-04-07 18:41:35.849] [info]    ndi[2|LAPTOP-KDN2J54S (Rotulos)] Source currently not available.

“TEST” is the name I gave to the NDI Bridge group to receive it. When I open NDI Monitor I can go to TEST / LAPTOP…/ Rotulos and see the source with no problem.

but with Caspar 2.3.3 I keep getting “Source currently not available”.

If anyone gets different results let us know!
Thanks

Privacy Policy   Terms of Service