Can't run scanner.exe (media-scanner not running) - 2.3.0 LTS Beta 1

Hi,
when amcp command is being sent to CasparCG 2.3.0 LTS Beta 1 I get an error that media-scanner isn’t running.
When I try to manually start “scanner.exe” via CMD I get this errors:

Any idea how to run media-scanner?

I’ve tried changing localhost to 127.0.0.1, didn’t worked…

Thanks :slight_smile:

Hi,
in both versions 2.2.0 and 2.3.0 whenever I add the part with consumer and ffmpeg, an media-scanner (scanner.exe) won’t run.
When I run it while using default casparcg.config then it runs fine.

Here is the whole config:

<?xml version="1.0" encoding="utf-8"?>

<configuration>
  <paths>
    <media-path>\\192.168.10.10\some_storage</media-path>
    <log-path>log/</log-path>
    <data-path>data/</data-path>
    <template-path>template/</template-path>
    <font-path>font/</font-path>
			  
				 
											 
					   
			
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
      <video-mode>720p5000</video-mode>
            <consumers>
				<ffmpeg>
			<path>rtmp://192.168.10.13:1935/test/stream1</path>
			<args>-codec:v libx264 -preset:v fast -crf:v 18 -codec:a aac -b:a 96k -ar:a 44100 -format flv</args>
		</ffmpeg>
		<ffmpeg>
			<path>rtmp://192.168.10.22:8888/test/stream2</path>
			<args>-codec:v libx264 -preset:v fast -crf:v 18 -codec:a aac -b:a 96k -ar:a 44100 -format flv</args>
		</ffmpeg>
            </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
        <media-server>
            <host>localhost</host>
            <port>8000</port>
        </media-server>
    </amcp>
</configuration>

Thanks!

Does anybody here read anything before asking the same question again? (For instance this).

@didikunz
With all due respect Didi, I’ve read all of that, also that’s for Linux (Ubuntu).
As I’ve written already, scanner starts fine when not using the ffmpeg/consumer part, so this seems to be another problem from what it’s described in topic you’ve posted.

Ok, so it seems, that I also do not read everything properly, sorry.

So you say, that you run Scanner.exe, by double clicking it (or use a batch script) before you start CasparCG.exe and that it stops working when you add that FFMPEG part in the config, right? Does Scanner.exe crash or just not respond to queryies?

Hehe, np :slight_smile:

Yes, it just crashes when FFMpeg part is in the config.

When I run it through CMD as admin I get the error I’ve posted in my first post screenshot.

It seems, that this line generates a XML parser error. I think that is a bug of the parser, as it is perfctly legal xml. Can you post a bug report on GitHub?

Posted on GitHub :slight_smile:

Privacy Policy   Terms of Service