Arabic fonts are not supported - Help!

Hi Guys,

Am glad i found this system and it works perfectly in English

However, am willing to use the system on my youtube live streaming, but the issue is that the Arabic fonts are not supported.

i tried to create a template through Adobe Animate and export it to CasperCG, however, if i write in Arabic, nothing is shown, i can see the animation, but not the text inside, while when i try the English text, it works

Any idea how can i do this?

Thank you all in advance

1 Like

The original Flash templates were built before “TLF” was supported in Flash so they don’t support full Unicode fonts and non-Latin scripts. Most people have moved on from Flash and are building HTML templates instead, but that requires a bit of coding skills. By building HTML templates you can use Unicode fonts with non-Latin Scripts, but make sure to use at least CasparCG Server 2.1beta or later to get an updated HTML Producer which supports modern (non-SVG) fonts.

We’ve built CasparCG HTML templates for the BBC that support all the 44 languages that they currently publish news in:

There are two things to note here: 1st You need to make sure that the font you embeed in your template accually supports Arabic and 2nd: That you embedd also the arabic glyphs. Then it works like a charm.

Am not a developer actually
Will you be able to guide me or to send an example ?
Thank you

My arabic templates are all copyright protected, so I should not give them out. But I can guide you a bit: If you right click in Animates library pane you can create a new Font. Then a dialog opens where you can select the font and style to embedd:

It’s from e German version but looks very similar in other languages. There were the red circle is select “ALL” or at least “Arabic”. I normally always select “All” as in Caspar the size of the final template is not SO important and the good thing is, that you have all the alphabeths that are present in the font.

Thanks for the info
I normally export the project to caspercg as png sequence is that also right ?

You mean, you import it in Animate as PNG sequence? What does that have to do with text not beeing displayed?

Still not showing, i can see the arabic text in the design, but not on Casper CG, and the arabic is also selected in the library

Post your .fla (and .as if you have one) file.

its not letting me upload FLA file here

i uploaded FT does this help?

CG Test.ft (636.1 KB)

No the ft does not help. So you have any Dropbox or similar thing were you can upload?

there you go both files

There were no dynamic texts in the template. The PNG sequence does NOT know how to render text. So I quickly added anything for you to test. Don’t use that in production IT IS UGLY! or I will never help you again :slight_smile:

What is also problematic, is, that from the point were the “outro” starts there is a lot of unnecessary frames until anything starts to move. Export only the parts were movement is and set the stop frame after the graphic is come to be fully “in” and then, from the stop frame it should only move out. I put the two texts inside a movieclip. You see that by inspecting the library pane. You can double click the movieclip to edit it’s content…

Thank you so much for your help, now half of the problem is solved, despite the fact that it showed that i was using dynamic text :frowning:

the problem now is that the Arabic text is not showing properly the letters are disconnected

any idea? disconnected

As I am swiss and have no idea about arabic, I don’t know. Probably the font is bad or the spaceing of the letters. But as I said: Don’t use this of anything other than to guide you the way. So change the font and position and animation etc.

My experience with the CS version Flash very good, and there is no problem without scripting skills for simple projects.

Hi guys,

thank you so much for all your help, i was able to figure things out today, it was hard but a good lesson

Yet, am sure that i will need your help very soon

thank you all

for those who are struggling writing in Arabic, you can use this website to convert the text

am sure there must be something easier but this is what i found so far

1 Like

When I try this on my CasparCG it won’t show the arabic fonts…
I’m struggeling with a problem my self, I have tryed to embed fonts in my template, but it doesn’t show up in CasparCG.
What am I doing wrong?

I have changed the type of the text field from classic text to TLF text . Advance action script setting -->Library path–>-->Text layout–>Link type–> Merged into code

Working file is attached

1 Like