You can change the integrated graphics card for the dedicated one in casparcg

I have an nvidia quadro P1000 graphics card and I want casparcg to use that card and not the one integrated in the pc.
Is it possible?

AFAIK it is not possible from inside Caspar. What you could do is switch Windows to use the nVidia card by disabling the integrated GPU. It depends on your motherboard how you can do this.

In Windows 11, almost sure also in Windows 10, you can set a video card for a specific application.

Under Settings/System/Display/Graphic you can select the application and then specify the video card to use.

Actually the options are something like this:

  • Let Windows decide
  • Power Saving (GPU: Intel UHD…)
  • High Performance (GPU: Nvidia…)

Solution works on Windws 10. Tested on a Windows 21H2 installation.

I disabled the integrated graphics card but when I want to run casparcg it tells me that the nvidia does not support OpenGL 4.5 but looking at the specs it says it does.

I did but always used the integrated :smiling_face_with_tear:

There is usually a way to disable it on hardware level. Maybe in the BIOS.

that is strange
If I were you I would try an older version of Caspar that require an earlier version of OpenGL. Just to see if you get the same error or not

a wild guess is that somehow the driver are corrupted, I saw many times suggestions to uninstall e re-install graphic driver.
But personally I never did, I don’t know if it is a safe thing to do nor if you can afford down time on that machine if anything doesn’t go well

Privacy Policy   Terms of Service