Windows 10 only showing in monitor 1

ive tried in all versions of caspar i can download and every time even though i set 2 for screen it never goes out the HDMI to monitor 2.

Is there something connected, so that the grapic card actually initialize the output?

Just to be sure, since you write very little about the issue, are you trying “full screen” right?

<windowed>false</windowed>

because if you are trying a “windowed” screen instead and the border is visible with:

<borderless>false</borderless>

then you can drag the window with the mouse
or you can simply try with the positioning in config:

<x>0</x>
<y>0</y>

with the desired coordinates in pixels.
Never tried the position for fullscreen, I don’t think it will work, but you can try if nothing else works

<device>2</device>

Doesn’t work for server 2.1 beta2.
It works for server 2.07 and NRK version and server2.3.

more info
yes there is a monitor connected via hdmi. my screens are set to extend desktop. its stuff i used to do all the time with casparcg a while back when i was on windows7.
yes i am trying to use it fullscreen borderless

i downloaded 2.07 to see if device worked and it doesnt. Even though i set it to device 2 it still shows in device 1 (and yes i did try with device 1 in the config just incase it got confused. Still in device main monitor.

tried with 2.3.3 with device and it didnt work. It ran full screen in device 1 and played fine.

tried using x1920 and bingo. the screen popped up in my 2nd monitor but… nothing played and casparcg crashed

Some system specs
Intel(R) Core™ i7-10750H CPU @ 2.60GHz 2.59 GHz
16.0 GB (15.8 GB usable)
GForce RTX 3060

just read somewhere i need openGL 4.6 and i notice in the log that casparCG is initializing openGL 4.5 downloading latest drivers and will let you know

it used to work before. seems the x trick is the only one to get the video over to the other monitor however when i set x to 0 it works, set to 1200 so it is inbetween screen it works. set to 1920 so it in in the 2nd monitor it crashes

found a laptop with windows 7. Downloaded 2.07 onto it and plugged in the 2nd monitor via hdmi and set windows to extend desktops. Told caspar config file to output onto screen device 2 and it worked like expected. All of this seems to be a windows 10 nightmare

looks like windows 10 or this laptop is foolishly not using all of my power.


monitor2

seems each monitor is using a different card. This might be the problem. ive googled how to make the laptop monitor (monitor1) use the geforce card but nothing the internet tells me to do works

UPDATE: just tested on my brothers computer. Both of his monitors are on the same graphics card and windows 10. Everything works perfect using device and x on that. But alas on mine no good. Im going to go over to the MSI forum and blast them for making a crappy laptop that would set the internal monitor to a crappy graphics chip and hdmi to the GeForce. makes no sense what so ever

quite strange, as a workaround I can suggest to try windowed and borderless.

<windowed>true</windowed>
<borderless>true</borderless>

with the correct x position [width and height if needed]
should appear as full screen but maybe doesn’t trigger any error

it crashes when i try that. this i dont see this as a caspar problem really. its just a hardware problem. setting x to 1920 means 0 is in monitor 1 on the Intel chip and its trying to shove it 1920 pixels to the right into monitor 2 which is run by the geforce. this is where carpar crashes trying to span two different cards. i read that in my laptop the internal monitor is wired to the intel chip and will never be able to run on the geforce card. cheap piece of crap

just tried to run the hdmi through a usb docking device and once again both monitors are showing dsifferent devices being used. and once again casparcg crashes. it cant seem to work if both monitors are running on different devices

ok seems i can launch a window in screen 1 and move it to screen 2 and it works. but i just cant launch it in screen 2

Did you try setting the x to 1919?

Kind regards,
Valentin

i tried everything. it has to do with the two monitors running on different graphics cards. it cant do it

Privacy Policy   Terms of Service