Waiting for audio frame


#1

Hi all,

We’re trying to play a live stream coming from Wowza with the following command:
PLAY 1-11 http://...:1935/OBVAN-LIVE/live-OB2/playlist.m3u8

Caspar shows us the following output:
[2019-12-22 11:17:02.745] [warning] ffmpeg[http://***:1935/OBVAN-LIVE/live-OB2/playlist.m3u8|0.0000/0.0000] Waiting for audio frame…

After about eight minutes, the video is finally shown, but the audio is not in sync. It’s minutes behind (probably about eight also…).

In VLC and FFMpeg, the video is played correctly.

Does anybody have any suggestions on how to troubleshoot/fix this?

Kind regards,
Pieter.


#2

You should use RTMP or RTSP from Wowza instead of HLS. You didn’t say what version you are using, there is better support for streams in the latest versions.


#3

Hi. Thanks for your reply!

I switched to rtmp and now I’m receiving this message:
[2019-12-22 21:03:43.498] [warning] [ffmpeg] [flv @ 0000022699A29B40] Invalid timestamps stream=1, pts=-30, dts=0, size=1919

The version I’m using is 2.3.0 d442a8f8

Any suggestions?


#4

It’s just a warning - I assume your stream is received fine?


#5

No it’s not. It’s not displayed.


#6

It looks like it only plays for a short while:


#7

Yeah 2.3 isn’t working for me as well. But 2.1.0.3440 f1ba60 worked fine.


#8

Hi. Should we report this to be fixed in the latest version?


#9

@hreinnbeck: I tried this today with the version you mentioned. It works, but the audio is behind. In some cases it works, but in most of the cases, it doesn’t. This is the message I get:

[OGL device] Performance warning. Buffer allocation blocked

When I open the Wowza stream in VLC, all is good. Also, when I open the stream in ffmpeg and save it to an mp4 file, the file plays in sync. So it really appears that something goes wrong in Caspar.

Any thoughts?