Videofile with multitrack audio

playout

#1

Hi everyone, what video/audio codec and file specs are needed to play multitrack audio from a videofile via Decklink embedded audio? I’m on 2.0.7. I changed the configuration file decklink audio to “passthru” but only get maximum two channels out of it.


#2

with this config i have 8 audios embedded, using XDCAM HD422 codec.
server 2.1, DUO2
unfortunately not all clients/server combinations are showing audio levels.
maybe someone has a hint for that? (all blackmagic mixers are processing only the first 2 audios, the other audios are eliminated)

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
<media-path>E:\media</media-path>
<log-path>E:\log/</log-path>
<data-path>E:\data/</data-path>
<template-path>E:\template</template-path>
<thumbnail-path>E:\thumbnail/</thumbnail-path>
<font-path>C:/Windows/fonts/</font-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  
  <mixer>
  <straight-alpha>false</straight-alpha>
  </mixer>

  <thumbnails>
     <generate-thumbnails>false</generate-thumbnails>
  </thumbnails>

<accelerator>auto</accelerator>

  <channels>
  <channel>
    <video-mode>1080i5000</video-mode>
    <straight-alpha-output>true</straight-alpha-output>
    <channel-layout>8ch</channel-layout>
      <consumers>
        <decklink>
          <device>1</device>
            <embedded-audio>true</embedded-audio>
            <channel-layout>8ch</channel-layout>
            <latency>low</latency>
            <keyer>external</keyer>
            <key-only>false</key-only>
            <buffer-depth>3</buffer-depth>
            <custom-allocator>true</custom-allocator>
        </decklink>
      </consumers>
  </channel>

  <channel>
    <video-mode>1080i5000</video-mode>
    <straight-alpha-output>true</straight-alpha-output>
    <channel-layout>8ch</channel-layout>
      <consumers>
        <decklink>
          <device>2</device>
            <embedded-audio>true</embedded-audio>
            <channel-layout>8ch</channel-layout>
            <latency>low</latency>
            <keyer>external</keyer>
            <key-only>false</key-only>
            <buffer-depth>3</buffer-depth>
            <custom-allocator>true</custom-allocator>
        </decklink>
      </consumers>
  </channel>
  </channels>

<audio>
  	<channel-layouts>
  	  		<channel-layout name="8ch"         type="8ch"         num-channels="8" />
  	</channel-layouts>
</audio>


  <controllers>
<tcp>
  <port>5250</port>
  <protocol>AMCP</protocol>
</tcp>
<tcp>
  <port>3250</port>
  <protocol>LOG</protocol>
</tcp>
  </controllers>
</configuration>

#3

Thanks Peter. I tried different versions. Multichannel works at least in 2.2.0. With your config and my files it does not work in 2.1.0 or 2.0.7. How do you build your XDCAM files that work in 2.1.0 ? In the end I would like to stay with 2.0.7 as some of my flash templates keep stuttering in >2.1.0 especially those with a png sequence in the background.


#4

Found it ! The config file needs to have the channel layout tag twice, ones below channel and another one below decklink. That was my bug. And the file needs to have one audio stream with 8 channel. 8 streams with one channel each do not work. Thanks again.


#5

If your png sequences stutter - make sure you mark them to be loaded in frame one in the library.
image


#6

Thanks for your hint. Didn’t know about this option. But sadly in my case it still stutters in >2.1.0. In
2.0.7 it’s perfectly smooth (1080p50). The beta versions anyways have some limitations especially performance wise. So I keep trying 2.2.0 but using 2.0.7.


#7

Hello Dirk,

could you please post your working casparcg.config as an example here. I tried as you advised, but without success…

Kind regards,
Martin


#8

I have the same problem, did you manage to get it working?

Can you send us an example of the config.

Thanks,
Gaspar.


#9

Sorry for the massive delay, too many things going on. Here is my working config with multichannel audio. Please note that the <channel-layout>passthru</channel-layout> needs to be set twice per channel.

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
    <media-path>E:\media</media-path>
    <log-path>log\</log-path>
    <data-path>data\</data-path>
    <template-path>E:\templates\</template-path>
    <thumbnails-path>E:\thumbnails\</thumbnails-path>
  </paths>
  <channels>
    <channel>
        <video-mode>1080p5000</video-mode>
	<channel-layout>passthru</channel-layout>
        <consumers>
           <decklink>
                <device>1</device>
		<key-device>1</key-device>
                <embedded-audio>true</embedded-audio>
		<channel-layout>passthru</channel-layout>
                <latency>normal</latency>
		<keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
                <custom-allocator>true</custom-allocator>
            </decklink>
        </consumers>
    </channel>
 	<channel>
        <channel-layout>passthru</channel-layout>
        <video-mode>1080p5000</video-mode>
        <consumers>
	<decklink>
                <device>2</device>
		<key-device>2</key-device>
                <embedded-audio>true</embedded-audio>
                <channel-layout>passthru</channel-layout>
                <latency>normal</latency>
		<keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
                <custom-allocator>true</custom-allocator>
            </decklink>
        </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
        <port>5250</port>
        <protocol>AMCP</protocol>
    </tcp>
  </controllers>
<audio>
   <channel-layouts>
     <channel-layout>
      <name>passthru</name>
      <type>16ch</type>
      <num-channels>16</num-channels>
      <channels />
    </channel-layout>
   </channel-layouts>
</audio>
</configuration>