Video Playout Faster Than Normal?

Hi, I’ve tried server version 2.0.7 and and noticed that with video mode 720p6000 and 1080p6000, any video playback I do plays slightly faster than 1x speed. I tried using clips encoded with H.264 and H.265 but the playback still plays at a faster speed. I’m not sure how to address this problem and was wondering if anybody could help me approach this.


In what framerate are the files encoded? By default Caspar plays videofiles using the framerate of the channel, not the file. So 50fps files play at 60fps on such a channel.

The files are 60fps. Here’s the ffprobe for the file:

    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : Lavf57.84.100
  Duration: 00:13:39.68, start: 0.000000, bitrate: 6173 kb/s
    Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720, 6000 kb/s, 60 fps, 60 tbr, 15360 tbn, 120 tbc (default)
      handler_name    : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 160 kb/s (default)
      handler_name    : SoundHandler

Looks like the audio sample rate is lower than the channels’ so it will sync it to the output device sample rate

I made another video with a sample rate of 48000 and CasparCG 2.0.7 still plays out the video at a slightly faster speed.

I have the same problem and therefore cannot upgrade from 2.0.7 to 2.2.0.

The files played are 25fps and 44khz. 2.0.7 plays that fine. (Broadcasted for over 180 hours without a problem!)

The audio in 2.2.0 sounds ‘flanged’(flanger) and indeed sounds like it tries to match some samplerate. (monitoring through system audio)

I understand that if the channel is 48khz the audio will do this. What I cannot find is how to set the sample rate of the channel? In the config file is only: ‘system audio’ defined and video mode which is set to 1080p2500 to match the content. I read that the audio will be transcoded realtime… I am lost… searched everywhere…

Thank you very much in advance!!! (I replied to this topic as it doesn’t seems to be solved yet.)

Can you post a bug report on Caspar’s GitHub page?

It seems as if this is the same issue as: #1170.

I will therefore just wait for an update and unfortunately stay with 2.0.7 for now…

I found some other posts from people having problems with 44khz audio. (I tried converting the file to 48khz but that didn’t help).

Thanks anyway!