Video Latency on Windows 11 PC

Hi,

I’m having an issue with CasperCG on my windows 11 PC. Video plays fine but the audio struggles and stutters through. It’s got a i7-12700f 2.16Hz, 32gb ram, RTX 3060 Ti.

There are other errors in the log, I’m not sure what they are referring too. Flash templates play out fine.

Any help would be appreciated, thanks.

LOG:

[2022-10-26 11:37:33.278] [info]    <?xml version="1.0" encoding="utf-8"?>
[2022-10-26 11:37:33.278] [info]    <configuration>
[2022-10-26 11:37:33.278] [info]       <paths>
[2022-10-26 11:37:33.278] [info]          <media-path>C:/CasparCG 2/media/</media-path>
[2022-10-26 11:37:33.278] [info]          <log-path>C:/CasparCG 2/log/</log-path>
[2022-10-26 11:37:33.278] [info]          <data-path>C:/CasparCG 2/data/</data-path>
[2022-10-26 11:37:33.278] [info]          <template-path>C:/CasparCG 2/templates/</template-path>
[2022-10-26 11:37:33.278] [info]       </paths>
[2022-10-26 11:37:33.278] [info]       <flash>
[2022-10-26 11:37:33.278] [info]          <enabled>true</enabled>
[2022-10-26 11:37:33.278] [info]          <buffer-depth>auto</buffer-depth>
[2022-10-26 11:37:33.278] [info]       </flash>
[2022-10-26 11:37:33.278] [info]       <channels>
[2022-10-26 11:37:33.278] [info]          <channel>
[2022-10-26 11:37:33.278] [info]             <video-mode>1080i5994</video-mode>
[2022-10-26 11:37:33.278] [info]             <consumers>
[2022-10-26 11:37:33.278] [info]                <decklink>
[2022-10-26 11:37:33.278] [info]                   <device>1</device>
[2022-10-26 11:37:33.278] [info]                   <embedded-audio>true</embedded-audio>
[2022-10-26 11:37:33.278] [info]                   <latency>normal</latency>
[2022-10-26 11:37:33.278] [info]                   <keyer>external</keyer>
[2022-10-26 11:37:33.278] [info]                   <key-only>false</key-only>
[2022-10-26 11:37:33.278] [info]                   <buffer-depth>3</buffer-depth>
[2022-10-26 11:37:33.278] [info]                </decklink>
[2022-10-26 11:37:33.278] [info]             </consumers>
[2022-10-26 11:37:33.278] [info]          </channel>
[2022-10-26 11:37:33.278] [info]          <channel>
[2022-10-26 11:37:33.278] [info]             <video-mode>1080i5994</video-mode>
[2022-10-26 11:37:33.278] [info]             <consumers>
[2022-10-26 11:37:33.278] [info]                <decklink>
[2022-10-26 11:37:33.278] [info]                   <device>2</device>
[2022-10-26 11:37:33.278] [info]                   <embedded-audio>true</embedded-audio>
[2022-10-26 11:37:33.278] [info]                   <latency>normal</latency>
[2022-10-26 11:37:33.278] [info]                   <keyer>external</keyer>
[2022-10-26 11:37:33.278] [info]                   <key-only>false</key-only>
[2022-10-26 11:37:33.278] [info]                   <buffer-depth>3</buffer-depth>
[2022-10-26 11:37:33.278] [info]                </decklink>
[2022-10-26 11:37:33.278] [info]             </consumers>
[2022-10-26 11:37:33.278] [info]          </channel>
[2022-10-26 11:37:33.278] [info]       </channels>
[2022-10-26 11:37:33.278] [info]       <controllers>
[2022-10-26 11:37:33.278] [info]          <tcp>
[2022-10-26 11:37:33.278] [info]             <port>5250</port>
[2022-10-26 11:37:33.278] [info]             <protocol>AMCP</protocol>
[2022-10-26 11:37:33.278] [info]          </tcp>
[2022-10-26 11:37:33.278] [info]       </controllers>
[2022-10-26 11:37:33.278] [info]       <amcp>
[2022-10-26 11:37:33.278] [info]          <media-server>
[2022-10-26 11:37:33.278] [info]             <host>Localhost</host>
[2022-10-26 11:37:33.278] [info]             <port>8000</port>
[2022-10-26 11:37:33.278] [info]          </media-server>
[2022-10-26 11:37:33.278] [info]       </amcp>
[2022-10-26 11:37:33.278] [info]    </configuration>
[2022-10-26 11:37:33.278] [info]    -----------------------------------------
[2022-10-26 11:37:33.281] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2022-10-26 11:37:33.281] [info]    video_channel[1|1080i5994] Successfully Initialized.
[2022-10-26 11:37:33.281] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 2
[2022-10-26 11:37:33.281] [info]    video_channel[2|1080i5994] Successfully Initialized.
[2022-10-26 11:37:33.287] [info]    [decklink_consumer] Uninitialized.
[2022-10-26 11:37:33.287] [error]   Exception: C:\Program Files (x86)\Jenkins\workspace\casparcg-server-dep\master\src\modules\decklink\consumer\decklink_consumer.cpp(441): Throw in function void __cdecl caspar::decklink::decklink_consumer::enable_video(enum _BMDDisplayMode)
[2022-10-26 11:37:33.287] [error]   Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::caspar_exception>
[2022-10-26 11:37:33.287] [error]   [struct caspar::tag_msg_info * __ptr64] = DeckLink Duo 2 [1-1|1080i5994] Could not enable fill video output.
[2022-10-26 11:37:33.287] [error]   [struct caspar::tag_stacktrace_info * __ptr64] =  0# 0x00007FF74495A53E in casparcg
[2022-10-26 11:37:33.287] [error]    1# 0x00007FF7449935B0 in casparcg
[2022-10-26 11:37:33.287] [error]    2# 0x00007FF744BC1433 in casparcg
[2022-10-26 11:37:33.287] [error]    3# 0x00007FF744BB9D71 in casparcg
[2022-10-26 11:37:33.287] [error]    4# 0x00007FF744BBC071 in casparcg
[2022-10-26 11:37:33.287] [error]    5# 0x00007FF7449AAF38 in casparcg
[2022-10-26 11:37:33.287] [error]    6# 0x00007FF744A4D5F2 in casparcg
[2022-10-26 11:37:33.287] [error]    7# 0x00007FF744A49F80 in casparcg
[2022-10-26 11:37:33.287] [error]    8# 0x00007FF744955279 in casparcg
[2022-10-26 11:37:33.287] [error]    9# recalloc in ucrtbase
[2022-10-26 11:37:33.287] [error]   10# BaseThreadInitThunk in KERNEL32
[2022-10-26 11:37:33.287] [error]   11# RtlUserThreadStart in ntdll
[2022-10-26 11:37:33.287] [error]   
[2022-10-26 11:37:33.287] [error]   
[2022-10-26 11:37:33.287] [error]    0# 0x00007FF74495A53E in casparcg
[2022-10-26 11:37:33.287] [error]    1# 0x00007FF744959E6F in casparcg
[2022-10-26 11:37:33.287] [error]    2# 0x00007FF744E57B3A in casparcg
[2022-10-26 11:37:33.287] [error]    3# 0x00007FFA6EBE1030 in VCRUNTIME140
[2022-10-26 11:37:33.287] [error]    4# is_exception_typeof in VCRUNTIME140
[2022-10-26 11:37:33.287] [error]    5# RtlCaptureContext2 in ntdll
[2022-10-26 11:37:33.287] [error]    6# 0x00007FF7449912EF in casparcg
[2022-10-26 11:37:33.287] [error]    7# 0x00007FF744993683 in casparcg
[2022-10-26 11:37:33.287] [error]    8# 0x00007FF74495DA1D in casparcg
[2022-10-26 11:37:33.287] [error]    9# 0x00007FF7449612DD in casparcg
[2022-10-26 11:37:33.287] [error]   10# 0x00007FF744DA0C28 in casparcg
[2022-10-26 11:37:33.287] [error]   11# BaseThreadInitThunk in KERNEL32
[2022-10-26 11:37:33.287] [error]   12# RtlUserThreadStart in ntdll
[2022-10-26 11:37:33.287] [error]   
[2022-10-26 11:37:33.356] [info]    [decklink_consumer] Uninitialized.
[2022-10-26 11:37:33.356] [error]   Exception: C:\Program Files (x86)\Jenkins\workspace\casparcg-server-dep\master\src\modules\decklink\consumer\decklink_consumer.cpp(441): Throw in function void __cdecl caspar::decklink::decklink_consumer::enable_video(enum _BMDDisplayMode)
[2022-10-26 11:37:33.356] [error]   Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::caspar_exception>
[2022-10-26 11:37:33.356] [error]   [struct caspar::tag_msg_info * __ptr64] = DeckLink Duo 2 [2-2|1080i5994] Could not enable fill video output.
[2022-10-26 11:37:33.356] [error]   [struct caspar::tag_stacktrace_info * __ptr64] =  0# 0x00007FF74495A53E in casparcg
[2022-10-26 11:37:33.356] [error]    1# 0x00007FF7449935B0 in casparcg
[2022-10-26 11:37:33.356] [error]    2# 0x00007FF744BC1433 in casparcg
[2022-10-26 11:37:33.356] [error]    3# 0x00007FF744BB9D71 in casparcg
[2022-10-26 11:37:33.356] [error]    4# 0x00007FF744BBC071 in casparcg
[2022-10-26 11:37:33.356] [error]    5# 0x00007FF7449AAF38 in casparcg
[2022-10-26 11:37:33.356] [error]    6# 0x00007FF744A4D5F2 in casparcg
[2022-10-26 11:37:33.356] [error]    7# 0x00007FF744A49F80 in casparcg
[2022-10-26 11:37:33.356] [error]    8# 0x00007FF744955279 in casparcg
[2022-10-26 11:37:33.356] [error]    9# recalloc in ucrtbase
[2022-10-26 11:37:33.356] [error]   10# BaseThreadInitThunk in KERNEL32
[2022-10-26 11:37:33.356] [error]   11# RtlUserThreadStart in ntdll
[2022-10-26 11:37:33.356] [error]   
[2022-10-26 11:37:33.356] [error]   
[2022-10-26 11:37:33.356] [error]    0# 0x00007FF74495A53E in casparcg
[2022-10-26 11:37:33.356] [error]    1# 0x00007FF744959E6F in casparcg
[2022-10-26 11:37:33.356] [error]    2# 0x00007FF744E57B3A in casparcg
[2022-10-26 11:37:33.356] [error]    3# 0x00007FFA6EBE1030 in VCRUNTIME140
[2022-10-26 11:37:33.356] [error]    4# is_exception_typeof in VCRUNTIME140
[2022-10-26 11:37:33.356] [error]    5# RtlCaptureContext2 in ntdll
[2022-10-26 11:37:33.356] [error]    6# 0x00007FF7449912EF in casparcg
[2022-10-26 11:37:33.356] [error]    7# 0x00007FF744993683 in casparcg
[2022-10-26 11:37:33.356] [error]    8# 0x00007FF74495DA1D in casparcg
[2022-10-26 11:37:33.356] [error]    9# 0x00007FF7449612DD in casparcg
[2022-10-26 11:37:33.356] [error]   10# 0x00007FF744DA0C28 in casparcg
[2022-10-26 11:37:33.356] [error]   11# BaseThreadInitThunk in KERNEL32
[2022-10-26 11:37:33.356] [error]   12# RtlUserThreadStart in ntdll
[2022-10-26 11:37:33.356] [error]   
[2022-10-26 11:37:33.402] [info]    Initialized channels.
[2022-10-26 11:37:33.402] [info]    Initialized command repository.
[2022-10-26 11:37:33.402] [info]    Initialized startup producers.
[2022-10-26 11:37:33.403] [info]    Initialized controllers.
[2022-10-26 11:37:33.403] [info]    Initialized osc.
[2022-10-26 11:37:38.285] [info]    Received message from Console: q\r\n
[2022-10-26 11:37:38.287] [info]    [asio] Shutting down global io_service.
[2022-10-26 11:37:38.287] [info]    [asio] Global io_service uninitialized.
[2022-10-26 11:37:38.397] [info]    video_channel[1|1080i5994] Uninitializing.
[2022-10-26 11:37:38.400] [info]    video_channel[2|1080i5994] Uninitializing.
[2022-10-26 11:37:38.426] [info]    Successfully shutdown CasparCG Server.
[2022-10-26 11:38:56.877] [info]

Does Caspar run as administrator?

Yes, the client, scanner and server run as administrator.

I’ve not used Win 11 but make sure your power management is disabled or set to maximum or ultimate performance.

With regard to the decklink errors - what decklink cards do you have installed? Is any other software trying to use the same devices?

The system is set for best performance. The PC has a decklink duo 2. No other software is using the decklink.

It could be a long shot but we had video issues because of a PCIe lane issue as pointed out by @didikunz in this topic.

The Decklink turned out to be using less than the 4 PCIe lanes and caused stuttering issues over a longer period or when adding more than 1 channel. Might be worth checking if you Decklink uses all of it’s PCIe lanes. Ours turned out it did not which caused all the issues, moving the Decklink to a different PCIe slot fixed it.

1 Like

I believe this could be the solution. It’s not using all the PCIe lanes to get the GFX out. The available PCIe slots are express slots and not the full 16x PCIe slot. The slots are big enough for the Decklink but not all pins are making contact. When I get a chance to do more testing I’ll confirm. Thanks for the advice.

I have the same issue with windows 10.
I am also using the Decklink Duo2 card. in my case, there is no Audio but the video is paying fine.

I need to restart the server every 2 or 3 days.

I ma using HP Z2 G8 Workstation intel Xeon W137 8Core 8GB AMD W5500 GFX card & 16GB ECC RAM

Privacy Policy   Terms of Service