Unexpected behaviour when playing interlaced media


#1

Hi, I have CS ver 2.2 and Blackmagic DeckLink Duo 2 set to 1080i50.
I have 1080i5000 video-mode in casparcg.config file.

When I am trying to play a 30 frames long clip (with fast horizontal motion - custom wipe for TV broadcast) usually the video is jerky. BUT NO EVERYTIME… Playing is absolut clear in about three out of ten attempts.
I don’t understand how it is possible.
Frame rate of the clip is 25 fps, Upper field first.

J


#2

From what you write it’s not possible to see the problem. It could be a performance problem of your PC or anything else. Du you see a difference, when you load the clip before playing (in the official client F3 loads the clip and F2 plays it)?


#3

I don’t think it’s a performance issue. My PC has good parameters (6 core Xeon, 3,6 GHz, NVidia P2000, 32 GB RAM, SSD disks etc.)
I have no problem with progressive clips. I have tried to play three clips in different layers at once without any issues.
Jerking in interlaced clip looks likewise wrong manipulation with fields.

I see this difference BUT just Yesterday. When I send LOADBG command before PLAY (F3, F2), interlaced clip plays fine in about 19 out of 20 attempts. Today without any changes in caspar,config, hw etc. the result is wrong in both cases (only F2 and F3+F2)

It is ablolut inconceivable for me.

Do You have some short interlaced mov clip which plays correct at Your machine?
Thanks.


#4

I think I was experiencing this while doing some testing the other day (in 2.2 or 2.3, don’t remember which). I was using a script to play the same clip (the go1080p25.mp4 sample) every few seconds, and sometimes it would play with what looked like the field order reversed.
I wasn’t sure if my case was down to sluggish performance due to running in debug mode, so was going to do more testing before writing it up


#5

Now I try it on v2.1.8_NRK and everything seems to be OK. Interlaced clip plays smooth every time.
We will see tomorrow :grinning:


#6

Is there some people/version/settings/workaround which plays the interlaced media 1080/50i correctly? That means without irregular wrong frame order?
I have tested the v2.1.8_NRK version, which is the only one playing correctly interlaced media, but there is another little bug with the CG INFO command and this version is therefore unusable for me too…:frowning:
CG INFO in NRK does not return the filename of the HTML file, which is currently playing in the channel-layer amd that is important information for my workflow.
J


#7

I never had any problems with any version of CasparCG in 1080i50. And believe me, I have a lot of channels running in that framerate. There must be something wrong elsewhere. Can you describe your setup (vision mixer etc.)?


#8

When trying something in 2.2 (or it might have been 2.3) I was getting what looked like inverted field order occasionally. I havent had a chance to look into the cause of it though


#9

6 core Xeon, 3,6 GHz, NVidia P2000, 32 GB RAM, SSD disks etc.
CS ver 2.2
Blackmagic DeckLink Duo 2 set to 1080i50.
1080i5000 video-mode in casparcg.config file
Blackmagic SDI-HDMI microconvertor
EIZO CS ColorEdge CS2420 autoset to 1080/50i, HDMI input

I am playing a simple small rectangle advertising animation in MOV with Animation codec, MIllions+, Upper Field First. The animation has horizontal movement and when repeating playback, randomly alternating the correct field order with the wrong field order…It is easy to see on the vertical edges.


#10

This is a computer monitor. Have you ever tried with a “real” broadcast monitor?


#11

I don’t think so, but it probably wouldn’t explain the fact that it works without problems in NRK 2.1.8…
I will try it this week.
This is the file


#12

The metadata of the file claims it’s bottom field first, if ffmpeg respects that you would get field order issues during the deinterlacing. If I use ffplay to play your file with the default deinterlacer it looks like a field order issue indeed.

2.2 is a progressive mixer pipeline so it always deinterlaces. 2.1 is an interlaced mixer pipeline so default is to not deinterlace.


#13

You are right, this file is bottom field first, but I have tryied both field order when I have exported the testing files from After Effects. The result was the same in both cases. - Sometimes Caspar plays fields with correct field order, sometimes with bad order. Is there some solution to correct this behaviour? The FILTER parameter in LOADBG command for instance or something else?


#14

I’ve also experienced this random behavior when playing interlaced media. Also with newer version of official distribution and very short clips/masks and with very strong hardware which should not have any problems handling this. Solution I use is to pre-render all such clips in full frame 50 fps.


#15

Thanks itod! Full frame 50 fps seems to be the best solution.