Trying out CasparCG but playout doesn't work and causes errors. Could someone help?

I have been trying to make CasparCG work, but every time I try to play something I get the following errors.

[2024-03-02 06:58:43.645] [info]    Received message from REQ qdixghc PLAY 1-10 "PAL_SD_16.9_ANAMORPHIC_PROGRESSIVE_QT_PNG_NONE_100_48KHZ1" SEEK 0 CLEAR_ON_404\r\n
[2024-03-02 06:58:43.651] [info]    Sent message to qdixghc 202 PLAY OK\r\n
[2024-03-02 06:58:43.676] [error]   Exception: No diagnostic information available.

[2024-03-02 06:58:43.676] [error]    0# 0x00007FF7F03F2C27 in casparcg
[2024-03-02 06:58:43.676] [error]    1# 0x00007FF7F03F26B5 in casparcg
[2024-03-02 06:58:43.676] [error]    2# 0x00007FF7F06BC3D9 in casparcg
[2024-03-02 06:58:43.676] [error]    3# 0x00007FFBB85E1080 in VCRUNTIME140_1
[2024-03-02 06:58:43.676] [error]    4# _NLG_Return2 in VCRUNTIME140_1
[2024-03-02 06:58:43.676] [error]    5# RtlCaptureContext2 in ntdll
[2024-03-02 06:58:43.676] [error]    6# 0x00007FF7F048FACD in casparcg
[2024-03-02 06:58:43.676] [error]    7# 0x00007FF7F048AB43 in casparcg
[2024-03-02 06:58:43.676] [error]    8# recalloc in ucrtbase
[2024-03-02 06:58:43.676] [error]    9# BaseThreadInitThunk in KERNEL32
[2024-03-02 06:58:43.676] [error]   10# RtlUserThreadStart in ntdll
[2024-03-02 06:58:43.676] [error]   
[2024-03-02 06:58:44.135] [warning] ffmpeg[PAL_SD_16.9_ANAMORPHIC_PROGRESSIVE_QT_PNG_NONE_100_48KHZ1|0.0000/2.0000] Latency: 4
[2024-03-02 06:58:44.136] [error]   Exception: Dynamic exception type: class std::future_error
[2024-03-02 06:58:44.136] [error]   std::exception::what: no state
[2024-03-02 06:58:44.136] [error]   

The video I am using came from ‘Download (CasparCG: Pro Video & Graphics Play-Out)’ to ensure it was not a problem with the files. I have tried my own video, image and audio files but none worked.

The following is my config

        <log-path disable="false">log/</log-path>
                <screen />
                <system-audio />

Have you tried running Caspar “as Administrator”?

I did try running it as admin, no difference.

What client are you using? Have you tried sending the command ‘manually’ to the server without the extra “seek 0…”?



Also, which version of the server are you using? The old 2.0.7 needed some c++ packages installed to work.

Pulled out my GPU and it worked off the Intel iGPU. I only have an AMD GPU so I can’t test with anything else. Thought it would work since the GitHub said other GPUs might work fine but I guess mine does not.

I used caspar cg client as well as superconductor. I have used server 2.3.3 as well as the newest beta master. I have tried to manually play before but the same issue. As I said before though, it works off my igpu so I guess the issue is with my gpu.