Stuck video files

Hi,

I have 2 issues i would like to get some assistance on. I have a 24 GB MKV file that i would like to play but somehow when i refresh the library it does not show up. It is the same MKV files i usually use. Is there any size limitation?

Secondly i deleted several video files from the media folder, but after refreshing the library those video files still show. When i try to play them nothing plays.

Is this a bug in the caspar that can be fixed?

Many Thanks
Csaba

Hi,

This is an addition to the above entry. After i restarted the computer the file showed up.
I started to play it, but after 1 minute the video channel collapsed. The picture was gone, audio was crackling, but the file was still playing. The video came back in frames on and off. I though maybe the file is too big (the video is 2 hour long). I restarted the server and i tried to play a 6 min video that was playing okay before. It did the same after a few minutes. It seems the output signal gets lost, but restarting the server fixes it temporary. Anybody has any ideas what is causing the error?

Without knowing much more about your system and your casparcg.config it is not possible to say anything, beside that it sounds like an odd performance problem.

the video going black is very unusual. Caspar will repeat frames rather than show black. Audio can go crackly when this happens.
How are you viewing the output? That sounds more likely to be the cause of black.

From memory it is a known bug that the scanner doesnt always detect files being deleted, and I have heard others having issues with it not detecting files but I don’t think anyone has tried to fix it

I use a 2.3.2 server with Client 2.2.0 on windows 11. Video card is a Geforce 1050 TI.
I use a decklink duo card connected to a blackmagic switcher.
I play video and audio out on 1 channel. This problem seems intermittent.
I have 3 channels (1 is key-fill, 2 and 3 individual).
The video plays the picture starts to cut out with audio crackling than picture stops but some audio output is still comes to the audio board but it is just some static signal.
When i restart the server the file plays again fine. Can it be a server bug?

What CPU, RAM, Harddisc / SSD? etc. Could you post the log file, when it shows the error? The more (use full) stuff you can give us, the better.

If you still see files that have been deleted, the workaround is to delete the folders _media, blob_storage, data and pouch__all_dbs__

This can be automated by editing casparcg_auto_restart.bat and adding the following to the top of the file -

Echo Deleting _media, blob_storage, data and pouch__all_dbs__...
rmdir /q/s _media
rmdir /q/s blob_storage
rmdir /q/s data
rmdir /q/s pouch__all_dbs__
Timeout /T 2

Guthub issue - CLS returning old list of media after changing media folder · Issue #1379 · CasparCG/server · GitHub

1 Like
Privacy Policy   Terms of Service