Streaming with CasparCG



Hi Guys,

I have a question about streaming with CasparCG-Server. I read alot of comments how to add a stream with ffmpeg. But i have a problem to fill the stream with content.

I have a setup like this:

  • CasparCG-Server 2.2 stable
  • VLC - Player

I add the Stream with this command:
ADD 2 STREAM udp://localhost:1234 -format mpegts -vcodec libx264 -crf 0 -tune zerolatency -preset ultrafast

and im setting up a reciever on VLC with: udp://@:1234

After this, VLC is recieving from CasparCG but i cant see something. So I guess, that my stream from Caspar is empty.
Now my question is: How can I add Content to the stream?

Maybe my thoughts are on a wrong way and you guys can help me. Our later goal of streaming is to stream an incoming SDI-signal to various IP-adresses.

Thanks for helping!



first of all with this ADD 2 command you are going to stream Channel 2 so confirm that your channel 2 is not empty.
second i don’t think that your streaming parameters are acceptable with 2.2 build. In server 2.2 ffmpeg updated with updated version so parameters are change in 2.2 so i’m sure you must be getting warning after adding stream check console for this.

you can try with

ADD 1 STREAM udp://localhost:1234 -format mpegts -codec:v libx264 -crf:v 0 -tune:v zerolatency -preset:v ultrafast


Yes i know - but thanks for this hint.

for me first testcase i just added a picture to layer 1 on channel 2. But i couldnt see it on my stream.

I tried this command and i didnt get any warnings like beofre. Thanks for that. But now vlc cant recieve anything and stays in search mode.

Maybe i have to smth in my config? I still have the standard one.

Am I getting it right? Normally you fill your layer with content as you want and then you add a stream with this command to your channel and it should now stream your whole channel content?

Thanks for your reply and help!



check console window for info/error

i’m testing it right now with same command and working fine on VLC

console info is:

[2019-04-10 20:42:48.106] [info] Received message from Console: ADD 1 STREAM udp://localhost:1234 -format mpegts -codec:v libx264 -crf:v 0 -tune:v zerolatency -preset:v ultrafast\r\n
#202 ADD OK
[2019-04-10 20:42:48.108] [info] ffmpeg[udp://localhost:1234] Initialized.
[2019-04-10 20:42:48.109] [info] [ffmpeg] [libx264 @ 0000000002742E40] using SAR=64/45
[2019-04-10 20:42:48.109] [info]
[2019-04-10 20:42:48.114] [info] [ffmpeg] [libx264 @ 0000000002742E40] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
[2019-04-10 20:42:48.114] [info]
[2019-04-10 20:42:48.117] [info] [ffmpeg] [libx264 @ 0000000002742E40] profile High 4:4:4 Predictive, level 3.1, 4:2:2, 8-bit
[2019-04-10 20:42:48.117] [info]

config is your default preset like if you want to start streaming with server start you can set it in config settings.


ok, I get the same console info like you. But my VLC is not recieving anything…

Anyways - thanks for your help!



Test using “” instead of localhost.


Thanks for this idea - but its the same result :confused: