Streaming changed in version 2.2

I’ve been using version 2.0.7 for streaming to a Wowza. This worked fine, but when I upgrade to version 2.2, all the settings seem to have changed. I see a couple of posts on this forum, but none of them seem to have a resolution.

Here’s the settings that I currently use in version 2.0.7:

-vcodec libx264 -preset fast -crf 22 -vf scale=720x480,format=pix_fmts=yuv420p -x264opts bitrate=1808:vbv-maxrate=1808:vbv-bufsize=61 -strict -2 -acodec aac -b:a 192k -af aresample=44100 -f flv

What would be the equivalent of this in 2.2?


Server 2.2 updated with newer version of ffmpeg and ffmpeg parameters is different in newer builds so try with

rtmp://******/Playout/Playout-stream -codec:v libx264 -preset:v fast -crf:v 22 -filters:v scale=720x480,format=yuv420p -b:v 1808k -maxrate:v 1808k -bufsize:v 61k -codec:a aac -b:a 192k -ar:a 44100 -format flv

Thanks noumaan,

The response is:
Unused option filters=scale=720x480,format=yuv420p:v

Wowza receives a stream, but there appears to be nothing in it.

Check with -filter:v

It doesn’t show me the error anymore and the stream is registered in Wowza, but it appears to be black.

I’m using latest version with UDP/TCP and it’s working fine. I didn’t test it with wowza or rtmp.
I think someone here was talking about this black stream issue.
Search this forum or GitHub issues if you find something helpful

Have you solved this issue?

Try without -vcodec libx264. I mean you don’t specify video codec.

In the end I added an NDI output and started the stream using OBS studio.

1 Like

Guys, please can you help with streaming into wowza? I have instaled wowza localy on the same machine as caspar client and server. In caspar screen I see playout is working. Using following I have added consumer to caspar server:

ADD 1 STREAM rtmp://caspar:caspar@ -codec:v libx264 -codec:a aac -strict -2 -b:a 128k -x264opts:v keyint=45 -ar:a 48000 -tune:v zerolatency -preset:v ultrafast -b:v 5750k -minrate:v 5000k -maxrate:v 6000k -bufsize:v 1146k -filter:v format=pix_fmts=yuv420p,scale=1280:720-format flv

In wowza I see incoming streem, but in test player just black screen appears. What is wron please?
See also folowing video, with what I described:

any hint please?

Hi, since the ffmpeg consumer changed several versions back, the frame size is not defined in an rtmp stream (if I remember correctly ffprobe sees it as -1*-1 and YouTube as 65535*65535), and that might be the problem. When I was dealing with this myself, people here recommended me using udp output and then repackaging it to rtmp using standard ffmpeg. Link to that topic is here: Rtmp streaming problems