Server 2.2.0 config file

config

#1

so I’m setting up the config file for server 2.2.0 and I having an issue with the Decklink consumer, i’m not getting an output

    <?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
    <media-path>media/</media-path>
    <log-path>log/</log-path>
    <data-path>data/</data-path>
    <template-path>template/</template-path>
    <font-path>font/</font-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
      <video-mode>1080i5994</video-mode>
      <consumers>
        <screen/>
        <system-audio/>
      </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>localhost</host>
      <port>8000</port>
    </media-server>
  </amcp>
</configuration>

<!--

<log-level> info  [trace|debug|info|warning|error|fatal]</log-level>
<template-hosts>
    <template-host>
        <video-mode />
        <filename />
        <width />
        <height />
    </template-host>
</template-hosts>
<flash>
    <buffer-depth>auto [auto|1..]</buffer-depth>
</flash>
<html>
    <remote-debugging-port>0 [0|1024-65535]</remote-debugging-port>
    <enable-gpu> true [true|false]</enable-gpu>
</html>
<channels>
    <channel>
        <video-mode>1080i5994 [PAL|NTSC|576p2500|720p2398|720p2400|720p2500|720p5000|720p2997|720p5994|720p3000|720p6000|1080p2398|1080p2400|1080i5000|1080i5994|1080i6000|1080p2500|1080p2997|1080p3000|1080p5000|1080p5994|1080p6000|1556p2398|1556p2400|1556p2500|dci1080p2398|dci1080p2400|dci1080p2500|2160p2398|2160p2400|2160p2500|2160p2997|2160p3000|2160p5000|2160p5994|2160p6000|dci2160p2398|dci2160p2400|dci2160p2500] </video-mode>
        <consumers>
            <decklink>
                <device>1[1..]</device>
                <key-device>device + 1 [1..]</key-device>
                <embedded-audio>true[true|false]</embedded-audio>
                <latency>normal [normal|low|default]</latency>
                <keyer>external [external|external_separate_device|internal|default]</keyer>
                <key-only>false [true|false]</key-only>
                <buffer-depth>3 [1..]</buffer-depth>
            </decklink>
            <system-audio>
                <channel-layout>stereo [mono|stereo|matrix]</channel-layout>
                <latency>200 [0..]</latency>
            </system-audio>
            <screen>
                <device>1 [1..]</device>
                <aspect-ratio>16:9 [default|4:3|16:9]</aspect-ratio>
                <stretch>fill [none|fill|uniform|uniform_to_fill]</stretch>
                <windowed>true [true|false]</windowed>
                <key-only>false [true|false]</key-only>
                <vsync>false [true|false]</vsync>
                <borderless>false [true|false]</borderless>
                <interactive>true [true|false]</interactive>
                <always-on-top>false [true|false]<</always-on-top>
                <x>0</x>
                <y>0</y>
                <width>0 (0=not set)</width>
                <height>0 (0=not set)</height>
            </screen>
            <newtek-ivga></newtek-ivga>
            <ffmpeg>
                <path>[file|url]</path>
                <args>[most ffmpeg arguments related to filtering and output codecs]</args>
            </ffmpeg>
        </consumers>
    </channel>
</channels>
<osc>
  <default-port>6250</default-port>
  <disable-send-to-amcp-clients>false [true|false]</disable-send-to-amcp-clients>
  <predefined-clients>
    <predefined-client>
      <address>127.0.0.1</address>
      <port>5250</port>
    </predefined-client>
  </predefined-clients>
</osc>
-->

#2

Currently this looks like the out-of-the-box default configuration, which only creates a windowed output (for testing), hence the “Screen” and “System Audio” consumers/outputs; this is why your DeckLink device is not outputting anything.

What you need to do is to insert a 'DeckLink" section as documented in the commented section further down.

This is just a basic, minimal example:

<decklink>
    <device>1</device>
    <embedded-audio>true</embedded-audio>
</decklink>

I’m using a DeckLink Duo 2, and this is what my configuration is at present (which creates fill and key but managed as a pair):

<decklink>
    <device>1</device>
    <embedded-audio>true</embedded-audio>
    <keyer>external_separate_device</keyer>
    <key-device>3</key-device>
</decklink>

I hope this gives some idea.


#3

thanks thats how i had it originally but I think i’m doing something wrong. if its not to much trouble would you mind sending me you config so i can compare and figure out where i went wrong


#4

You can use the external key mode with a duo 2 instead of external_separate_device.
Using external will perform better and has a stronger guarantee on frame accuracy.
Just remove the keyer and key-device sections to your config, and in the Desktop Video Setup utility, set the duo to pair SDI 1 & 3 for the first channel


#5

Can you post your log file with the decklink configuration added to the config file?
That will help determine the problem.


#6

ahhh thanks Julusian I totaly didn’t add it to the file. :disappointed:
that’s embarrassing


#7

Here’s my configuration (2.2.0 STABLE dated 2018-12-29) as in the configuration file, LateGreat; please note that I do have different paths set (notably LOG and THUMBNAILS pointing to a small ramdisk).

<configuration>
	<paths>
		<data-path>media\</data-path>
		<font-path>media\</font-path>
		<media-path>media\</media-path>
		<log-path>r:\</log-path>
		<template-path>media\</template-path>
		<thumbnails-path>r:\</thumbnails-path>
	</paths>
	<log-level>error</log-level>
	<auto-mode>true</auto-mode>
	<thumbnails><generate-thumbnails>false</generate-thumbnails></thumbnails>
	<html><enable-gpu>true</enable-gpu></html>
	<controllers>
		<tcp><protocol>AMCP</protocol><port>5250</port></tcp>
	</controllers>
	<channels>
		<channel><video-mode>720p5000</video-mode>
			<consumers>
				<decklink><device>1</device>
					<keyer>external_separate_device</keyer>
    					<key-device>3</key-device>
				</decklink>
			</consumers>
		</channel>
	</channels>
</configuration>

I understand what you’re saying in terms of tying sockets 1 and 3 together, Julusian, but the reason I have it set up this way is that I have an external switcher (an old ATEM Television Studio) doing the final layering (on its SDIs 5 and 6 for fill and key respectively). I actually tried EXTERNAL mode, I got the fill on SDI-5, but nothing showed up on SDI-6; I think this is more for when the system is sandwiched between two other devices.


#8

You don’t really need to use two SDI inputs for what your doing. on your atem you can key it over black or superkey it and adjust clipping to get the right transparancey. It works very well if you key has a transparent background. And will open up an input on your switcher.


#9

I did try to it that way initially but I could not get darker colours to display correctly. The way I am understanding it, from an “ARGB” standpoint, is that the fill is the “RGB” and the key is the “A”. In the end, I opted to pre-key by “having the source tell the destination what is opaque, translucent or transparent” because, for me, it eliminates the amount of reconfiguration time on-the-whole.

So far, I’ve not encountered a situation that required 6 unique sources; the closest I can recall is 4.


#10

@jamie6600 I too use that to connect to multiple inputs on an atem. I’m not sure why it didn’t work for you, but it should do.

@LateGreat that trick sometimes works, but it depends on exactly what content you are playing out. I have done it before when I know there is one maybe two graphics to tune it to that are consistent on colour or have no transparency, but it is generally much simpler to use 2 sdi as you just tick the premultiplied box on the atem and everything looks as it should.

@jamie6600 yes, you are right in that is how it translates to the fill and key signals.