Scanner media problem in version 2.2 Stable

Hi,

I have a problem running scanner.exe on Dell Precision Rack 7910, when I try to run the application, the window appears for a moment and disappears, and the application does not start. I deleted the reference to the “media" folder in the casparcg.config file and all files in the "pouch__all_dbs_” folder. I’m trying to run the application on Windows 10 Professional ver. 1803. Below is the config file and photo with installed programs and libraries.

Thank you for all the tips, because I lack ideas.

Blockquote


log/
data/
K:\T24\Templates</template-path>
font/

info
error
warning
debug
trace

auto

secret


1080i5000


1
false
low
external
3
true






5250
AMCP




localhost
8000


<configuration>
  <paths>
    <log-path>log/</log-path>
    <data-path>data/</data-path>
    <template-path>K:\T24\Templates\</template-path>
    <font-path>font/</font-path>
  </paths>
  <log-level>info</log-level>
  <log-level>error</log-level>
  <log-level>warning</log-level>
  <log-level>debug</log-level>
  <log-level>trace</log-level>
  <flash>
    <buffer-depth>auto</buffer-depth>
</flash>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
        <video-mode>1080i5000</video-mode>
        <consumers>
            <decklink>
                <device>1</device>
                <embedded-audio>false</embedded-audio>
                <latency>low</latency>
				<keyer>external</keyer>
				<buffer-depth>3</buffer-depth>
				<custom-allocator>true</custom-allocator>
            </decklink>
	</consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>localhost</host>
      <port>8000</port>
    </media-server>
  </amcp>
</configuration>

First of all you should only have one log-level line. That is a setting were you have to choose one.

But the invalid log-level setting should not kill the scanner??

I have exactly the same problem on 3 different Windows 10 PCs. When started (either manually or via .bat file) the scanner closes immediatley the window (exits).

I’m running CasparCG server 2.07 on those machines successfully for several years now and never had an issue.

Is there a log file for the scanner somewhere?

Thanks for any insights,

Knut

Check template path “/” and media, if not exists, just add media/

Installed CasparCG-2.2.0-stable on a laptop with fresh Windows 10 installation. It is working there (CasparCG & media-scanner).

On the PC where media-scanner is not working (but CasparCG) I have installed NodeJS. Could this interfere somehow?

When I start scanner in the commandshell it throws me this error:

G:\casparcg-server-2.2.0-stable>scanner
pkg/prelude/bootstrap.js:1172
      throw error;
      ^

TypeError: Cannot read property 'paths' of undefined
    at parser.parseString (C:\snapshot\media-scanner\src\config.js:0:0)
    at Parser.<anonymous> (C:\snapshot\media-scanner\node_modules\xml2js\lib\parser.js:303:18)
    at emitOne (events.js:116:13)
    at Parser.emit (events.js:211:7)
    at SAXParser.onclosetag (C:\snapshot\media-scanner\node_modules\xml2js\lib\parser.js:261:26)
    at emit (C:\snapshot\media-scanner\node_modules\sax\lib\sax.js:624:35)
    at emitNode (C:\snapshot\media-scanner\node_modules\sax\lib\sax.js:629:5)
    at closeTag (C:\snapshot\media-scanner\node_modules\sax\lib\sax.js:889:7)
    at SAXParser.write (C:\snapshot\media-scanner\node_modules\sax\lib\sax.js:1436:13)
    at Parser.exports.Parser.Parser.parseString (C:\snapshot\media-scanner\node_modules\xml2js\lib\parser.js:322:31)
<?xml version="1.0" encoding="utf-8"?>
<!-- <log-level>       trace [trace|debug|info|warning|error]</log-level>
-->
<log-level>debug</log-level>
<configuration>
  <paths>

    <media-path>MEDIA/</media-path>
    <log-path>LOG/</log-path>
    <data-path>DATA/</data-path>
    <template-path>TEMPLATE/</template-path>
    <font-path>FONT/</font-path>
    <!-- <thumbnail-path>G:/_CCG/THUMBS</thumbnail-path> -->

  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
        <video-mode>1080i5000</video-mode>
        <consumers>
          <screen>
            <device>1</device>
            <always-on-top>true</always-on-top>
            <x>0</x>
            <y>0</y>
            <width>480</width>
            <height>270</height>
          </screen>
          <system-audio />
        </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
        <port>5250</port>
        <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>127.0.0.1</host>
      <port>8000</port>
    </media-server>
  </amcp>
</configuration>

<configuration>
Shoud be the first tag and
<log-level>
Should be inside it

1 Like

OMG Shame on me…

thanks so much…

Privacy Policy   Terms of Service