Ross MC1 alpha key issue

forum
config
keyer

#1

Hi Guys,
I am facing issues with Ross MC1 switcher. I have used decklink duo card and default config file. In output 1 Key is there and output 2 fill is available. But when I am connecting alpha and fill to MC1 switcher interface templates are getting transparent . I have tried adding straight-alpha to true in config file. But no luck. Please suggest…

Thanks,
Abhaya


#2

How does your signals look when you just connect it to an an monitor without the switcher in between?


#3

You first need to enable <mixer><straight_alpha/>true</straight_alpha></mixer>.

Then you need to enable <straight_alpha_output>true</straight_alpha_output> either by setting this to true to each channel, or using mixer [channel] straight_alpha_output 1


#4

Hello Guys,

I have a similar problem at the moment. I’m trying to do straight fill + key output via MacBook Pro and Ultrastudio 4k. Works pretty fine with premultiplied fill + key. But the switcher I’m using only accepts straight fill. Adding the mixer command and the channel config for straight output does not change the fill output to straight. Any suggestions ? Here is my config. I’m on 2.0.7.

Thanks in advance
Best Dirk

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
    <media-path>c:\media\</media-path>
    <log-path>log\</log-path>
    <data-path>data\</data-path>
    <template-path>c:\templates\</template-path>
    <thumbnails-path>thumbnails\</thumbnails-path>
  </paths>
<mixer><straight_alpha>true</straight_alpha></mixer>
  <channels>
	<channel>
        <video-mode>1080i5000</video-mode>
	<straight_alpha_output>true</straight_alpha_output>
        <consumers>
	<decklink>
                <device>1</device>
		<key-device>1</key-device>
                <embedded-audio>true</embedded-audio>
                <channel-layout>stereo</channel-layout>
                <latency>normal</latency>
                <keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
                <custom-allocator>true</custom-allocator>
            </decklink>
	<buffer-depth>auto</buffer-depth>
	<system-audio></system-audio>
        </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
        <port>5250</port>
        <protocol>AMCP</protocol>
    </tcp>
  </controllers>
</configuration>

#5

The mixer lines must read:

<mixer>
	<straight-alpha>true</straight-alpha>
</mixer>

#6

Thanks for your idea. But the fill does not change to straight from changing “-” to a “_” in the mixer command. Is there a specific type of codec that need to be used for straight output ? I’m trying with a transparent png. The CG1080i50 Video does not work as well.


#7

Sorry I was wrong, I had the impression that you had a typo in your config, but that was wrong. You only see a difference in the way the fill looks, when you have half-transparent areas. The CG1080i50 video is rendered as premultiplied and will probably not change. And transparent png’s are premultiplied also. You should try with a TGA to see the difference.


#8

Or you could try one of these


#9

Thanks for the files. Your TGA file always shows the “Straight” Information on the left side. No matter if the configuration is with or without the straight alpha options. How do I make such TGA files ? Photoshop seems to fail with transparency. So there is no difference in the fill.


#10

I also tried now to have to file with no transparency and the alpha in a separate file _A. The fill is always premultiplied no matter what settings I use.


#11

I have found an error in the server console.
TextureBarrierNV not supported. Post processing would no be available
Is it possible that the straight output function is not available due to the graphicscard in my MacBookPro does not support it ?


#12

If you only look at the fill then it makes no difference. You need to hook it up to a vision mixer and watch it after it is overlayed to another picture. Or do you?


#13

Yes I believe that straight alpha output and blend modes both require an NVIDIA gpu to work in 2.1 or older


#14

Yes I also looked at the result from the switcher and that looks right. I also found a way to make my own TGA with transparency. You have to enable channels in Photoshop and edit RGB and Alpha separate.

So it looks like TGA is always processed Straight (as it is Straight) and PNG is always processed PreMultiplied (as it is) if the graphics card does not support converting in between those two. Mine only supports OpenGL 4.3.


#15

Success ! I found another MacBookPro Machine with a Nvidia GT750M that supports OpenGL4.5. The right config for straight output is also ALL options with “-” not “_” ! Thanks a lot for your ideas that help me finding the issue!

Here is my working config:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
    <media-path>c:\media\</media-path>
    <log-path>log\</log-path>
    <data-path>data\</data-path>
    <template-path>c:\templates\</template-path>
    <thumbnails-path>thumbnails\</thumbnails-path>
  </paths>
<mixer>
    <straight-alpha>true</straight-alpha>
</mixer>
  <channels>
	<channel>
        <video-mode>1080i5000</video-mode>
	    <straight-alpha-output>true</straight-alpha-output>
        <consumers>
	<decklink>
                <device>1</device>
		        <key-device>1</key-device>
                <embedded-audio>true</embedded-audio>
                <channel-layout>stereo</channel-layout>
                <latency>normal</latency>
                <keyer>external</keyer>
                <key-only>false</key-only>
                <buffer-depth>3</buffer-depth>
                <custom-allocator>true</custom-allocator>
            </decklink>
	<system-audio></system-audio>
        </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
        <port>5250</port>
        <protocol>AMCP</protocol>
    </tcp>
  </controllers>
</configuration>