RED CAST - streaming to Wowza

Hello,

how can I put stream from Caspar CG to Wowza? I have Wowza rtmp url, but if I put it into Red cast settings, nothing happen, Wowza does not detect any video.
Should it work also from localhost?

Thank you

1 Like

With following command in servre 2.2 I was able to stream to wowza server.

ADD 1 STREAM rtmp://user1:password1@127.0.0.1:1935/live/myStream -codec:v libx264 -codec:a aac -strict -2  -b:a 128k -x264opts:v keyint=45 -ar:a 48000 -tune:v zerolatency -preset:v ultrafast -b:v 750k -minrate:v 500k -maxrate:v 1000k -bufsize:v 1146k -filter:v format=pix_fmts=yuv420p -format flv

In the live incoming stream pannel I can see available myStream. In the vlc I can see it by putting

rtmp://127.0.0.1:1935/live/myStream

thanks so much, now it looks, wowza has inbound trafic, it got me following info:

Inbound: Connected	Yes
Inbound Bitrate: Actual	723.7 Kbps
Outbound Bitrate: Actual	506 Kbps
Outbound Bitrate: Configured	9168.0 Kbps
CPU Usage	3 %
Frame Size	1280x720
Frame Rate	50 FPS
Keyframe Interval	45 GOP
Total Unique Viewers

I was able to change gop size warning, but i do not know where to change frame size. Wowza says:

Configured frame size is different from what Wowza Streaming Cloud is receiving from the source

but in server settings I have following lines

<video-mode>720p5000</video-mode>

From CasparCG server probably flows rtmp with bad resolution, because there was following info:

[2019-08-07 19:37:35.116] [info]
[2019-08-07 19:37:35.118] [info]    [ffmpeg] [libx264 @ 00000137DB391000] frame I:105   Avg QP:40.63  **size: 21446**
[2019-08-07 19:37:35.118] [info]
[2019-08-07 19:37:35.118] [info]    [ffmpeg] [libx264 @ 00000137DB391000] frame P:5136  Avg QP:43.65  **size:  1523**

so what is wrong?

Btw I have still no frames displayed in wowza/ no picture, but I assume, it is because of frame size warning.

Please, anyone some idea? Why wowza give me warning on Frame Size 1280x720 ?? Or how to change it on caspar output?

For changing the resolution to 1920:1080 try following code in server 2.2 or 2.3

ADD 1 STREAM rtmp://user1:password1@127.0.0.1:1935/live/myStream -codec:v libx264 -codec:a aac -strict -2  -b:a 128k -x264opts:v keyint=45 -ar:a 48000 -tune:v zerolatency -preset:v ultrafast -b:v 5750k -minrate:v 5000k -maxrate:v 6000k -bufsize:v 1146k -filter:v format=pix_fmts=yuv420p,scale=1920:1080 -format flv

I have just added -filter:v format=pix_fmts=yuv420p,scale=1920:1080

Hi @vimlesh1975,

I do not know what I am doing wrong. Wowza still didplays no video. I have tried to use CMP (before I used just basic client or RedCast), but still not beter result Wowza still seems to receive framesize 0x0.

any help please?

Have you succeeded? Did you solve the problem?

Unfortunately not, but dealing again with similar topic, so maybe will have more sucess.

Any updates on this issue? I am trying to stream to Wowza using 2.3.3 and getting the no video as well

PLAY 1 1.mp4 LOOP

ADD 1 STREAM rtmp://user1:password1@127.0.0.1:1935/live/myStream -codec:v libx264 -codec:a aac -strict -2  -b:a 128k -x264opts:v keyint=45 -ar:a 48000 -tune:v zerolatency -preset:v ultrafast -b:v 750k -minrate:v 500k -maxrate:v 1000k -bufsize:v 1146k -filter:v format=pix_fmts=yuv420p -format flv

I used the above command, but no luck. Any suggestions would be appreciated. Thanks

Please, how can i do for streming youtube

Hi!
the issue others faced has since been fixed (670bec3), however there is not yet any stable release including the fix.

If you need this functionality, you can use “unstable” builds from here: Index of /builds/CasparCG Server/master

Then streaming to YouTube (and other services) is as expected, e.g. for 6Mbps stereo stream something like this:

ADD 1 STREAM rtmp://[URL]/[KEY]  -codec:v libx264 -x264opts:v keyint=50 -preset:v faster -codec:a aac -strict -2  -b:a 128k -ar:a 48k -b:v 6M -maxrate:v 6500k -bufsize:v 2M -filter:v format=pix_fmts=yuv420p,fps=25 -filter:a pan=stereo|c0=c0|c1=c1 -format flv

where [URL] is stream server url provided by the service - for YouTube probably rtmp://a.rtmp.youtube.com/live2
and [KEY] is your stream key, similar to 1234-abcd-efgh-5i6j-7k8l
For the other parameters look at ffmpeg documentation

EDIT: changed link of “unstable” builds because Temporary build download links · Issue #1439 · CasparCG/server · GitHub

Privacy Policy   Terms of Service