Recording on USB-Drive & streaming rtmp


#1

Hey,
I guess these are my first lines in something like a forum or community board ever. So hello.
I’ working in the media industrie, primarily in the live broadcasting sector. Whatever…

I could use some help, developing a system using CasparCG Server and a selfwritten CasparCG Client.

basic setup:

  • Camera sends HD-SDI to Blackmagic Decklink card
  • Computer overlays CG content
  • Output to some several Computer in the network via NDI
  • FFMPEG Consumer captures the camera input plus the graphical overlay directly on an USB-Flashdrive

most features are working fine.

problem:
I can’t manage to save the recored file directly on the USB-Flashdrive, without setting the Mediapath to this location.

  • Is there a way, to save that file on an absolute filepath?

Thanks in advance! :v:


#2

AFAIK not, but you could try with a junction or symbolic link in Windows, that points to the drive.


#3

Great. I think junction will do the job.
Thanks!

Another problem I have, is setting up a working videostream via rtmp. CasparCG seems to get a connection with the recieving unit. But the videostream, that arrives is all black.

I’m using following command:
ADD 1 STREAM rtmp://live.restream.io/live/streamkey -vcodec libx264 -f flv -ar 44100

Same problem with UPD streaming.
VLC-Player recognizes there is an incomming stream, but the video’s content stays black

I’m not getting any errors from the CasparCG Server.


#4

try using Server 2.1 Beta 2
it can save file to your defined path


#5

-pix_fmt yuv420p


#6

Not necesarily. You can pass an absolute path to the ADD command. Try with:

ADD 1 FILE "D://my_custom_path//to_the_folder//where_i_want//my_record_file.mp4" -codec:v libx264 -threads:v 4 -preset:v veryfast

And it should record the file where you specified. Keep in mind that path separators must be escaped as // instead of \ and put your path in double quotes.


#7

Worked, thanks!

worked perfectly! thanks