Recording into a File causes Caspar CG Server process crash - v. 2.1.12.12436 11fdd364e NRK x64

Hi there, just a question if I’m allowed

After having installed NRK and doing the rest of procedures, everything worked properly except recording into a file.

While playing something, for instance:
PLAY 1-10 “MISCELANEO/NUBES_TIEMPO” 1 CUT 1 Linear RIGHT LOOP

I execute: ADD 1 FILE “RECORDS/cinco.mov” -vcodec prores -preset ultrafast -tune fastdecode

RECORDS ist just a folder under Media directory, and “cinco.mov” is the name of the file

Caspar start recording as usual and the messages are shown:
ffmpeg_consumer[RECORDS/cinco.mov] Initialized.
:202 ADD OK

±-----------------------+
** | ffmpeg_consumer_buffer |default–[1920x1080 1:1 bgra]–auto_scaler_0:default**
** | (buffer) |**
±-----------------------+

… etc, etc …

I can see how file cinco.mov is growing while recording but when I exectue
REMOVE 1 FILE “RECORDS/cinco.mov”
in order to stop recording then the messages
202 REMOVE OK\r\n
[ffmpeg_consumer] Uninitialized.
are shown and inmediately Caspar process crashes.

As a result the file “cinco.mov” is not possible to be played, probably because wasn’t closed properly.

Have you noticed something like this? is there anyway to fix this issue?

Thanks a lot.

Just for curiosity: Have you ever tried the same without giving the .mov extension? If that does not help please check if that bug is already reported and if not file a bug report on Caspar’s GitHub page.

This is a known issue Server Crashing with Remove 1 File · Issue #45 · nrkno/tv-automation-casparcg-server · GitHub
There is a workaround of compiling and running a ReleaseWithDeb build of casparcg, but that has a performance penalty and so is not the default.

Am I right by expecting, that this is only in the NRK branch?

Hello Didikunz, the same effect occurs if I execute

add 1 File “abc.mp4”

(file growing, everything ok)

remove 1 file

(Caspar CG crashes)

Ok, clear, according to @Julusian that seems to be a known issue. Please try with another version of Caspar.

Correct, this isnt a problem in 2.3.
I don’t remember if we tested the SVT 2.1 betas, so I cant comment on that

In this case I request you to please spare some to make a last 2.1 version flash compatible. This version works ok with file record and file remove.

Thanks, Julusian, the problem is we have developed a program which works perfect with NRK. I would have to check a lot of things if we upgrade to 2.3.

But, talking about the Workaround you told before, which would be the procedure?

In Server Crashing with Remove 1 File · Issue #45 · nrkno/tv-automation-casparcg-server · GitHub
sparkpunkd says:

This is a known problem with thee FFmpeg consumer on Windows, affecting REMOVE FILE and REMOVE STREAM … or a sequence of 2 ADD FILEs or 2 ADD STREAMs. Through experiment, it has been shown that this can be avoided by compiling with /INCREMENTAL linking or by selecting a build type of ReleaseWithDbgInfo (which switches on incremental linking!).

Shoud I download source code and compile with /INCREMENTAL linking? Where I can get a build type of ReleaseWithDbgInfo ?

Thanks

Privacy Policy   Terms of Service