Question about screen consumer


#1

So im having a problem that has me stumped. Playing out video just fine (screen consumer is the actual computer screen output (hdmi) on monitor card. No matter what i change in the config file im still getting a windowed screen. What am i missing?current config.htm (8.9 KB)


#4
1080i5994 stereo 1 false true

and then later:

        <screen>
            <device>[0..]</device>
            <aspect-ratio>default [default|4:3|16:9]</aspect-ratio>
            <stretch>fill [none|fill|uniform|uniform_to_fill]</stretch>
            <windowed>false [true|false]</windowed>
            <key-only>false [true|false]</key-only>
            <auto-deinterlace>true [true|false]</auto-deinterlace>
            <vsync>false [true|false]</vsync>
            <interactive>true [true|false]</interactive>
            <borderless>false [true|false]</borderless>
        </screen>

#5

Is that what windowed means?


#6

This is NOT VALID XML! This is copied from the comented howto section. Everything listed between square brackets is meant to show, what the possible settings are. Only one of these can exist in the final config. So, for instance the borderless line must either read:

<borderless>true</borderless>

or

<borderless>false</borderless>

otherways the config will not work and only use defaults.


#7

Do you mean a full screen image without window borders? That can be achieved by setting windowed to false:

<screen>
  <device>1</device>
  <windowed>false</windowed>
</screen>

That will yield a screen filled with the image. Keep in mind that device determines which screen will show your screen consumer.


#8

make your config like noquierouser explained:

i have ULTRAMON installed on the screen consumer pc, you can make a ULTRAMON keyboard shortcut to move the active window to a second screen, so i move the screen consumer window away and can see my desktop again. windows 10 should do this also without any additional software, but i could not bring it to work.


#9

The line
<device>1</device>
defines the monitor to use. Normally the main desktop monitor, were the taskbar is shown is number 1. So to use 2 should move it to the other screen. There is a button in the screen control panel applet, that let you identify the screens, I think these numbers are the ones to use, but I did not try…