Problems with audio on NTSC

Hello guys, i need a help here

I’m using casparcg for more than a year for playout solutions in our studio, but so far it was only videos without audios. But recently we change some of then to work with audio, but every time I play any file with audio it has some cliping noise.
What I already try:
Servers: from 2.0.7 to 2.3
audio files: wav, aac, mp3, all in 44 ou 48khz (many diferent files)
video files: mp4(h264), mov(apple pro res), mxf(dnxhd) (many diferent files)
framerates: i5997, p2997, p5994 (many diferent files)

It seems only work when I’m in 50 or 60fps, but if it is 5994 or 2997, it clips… It is a bug, or am I doing something wrong?

Just to complete my question, I already try to output to decklink, screen/system audio an ndi, an the result is the same in all of then, in more than 1 machine, with the hardware recommended

Just to be sure, these files all work properly with other players (i.e.vlc, ffplay, mplayer)? And what does “clipping noise” mean? (I’ve not had any problems with audio clipping with multiple version of the server.)


z, I will make some tests today and record then and post here with more information, and just for you know, I’ve made test with the songs that youtube give for free to use in their channels, they play ok in media players (vlc, ffplay, mplayer, window media), but in caspar I have this problem.

So, here are the results for the test. In this folder is a main song, and the results recorded from each server version and different frame rate.

So, is this a bug? Or a miss config?

This is a bug, has been reported on GitHub already. No ETA for a fix unfortunately, PR is welcome of course.

Thanks balte, I leave a comment in git too about this…

I successfully solved peaking noise by setting volume to 0.9 with:


It’s not really how you should do it, but some files are just encoded with too loud audio.

Hope it helps :slight_smile: