Problem with HTML template CasparCG 2.0.7 server

I have a problem with html template rendering on windows 7 and caspar cg 2.0.7. When I send the add command, this is what comes out.
casparerror

On another computer with windows 10 and caspar cg 2.3.0 it is rendered normally.
I tried to register this in caspar.config:

<template-path>C:\\Users\\dalet\\Desktop\\Server1\\templates</template-path>

but then it outputs this:
casparerror1

How can I solve this problem?

There seems to be a syntax error in your java script on line 21…

I make a template through “loopic” and everything is generated automatically there. And it works fine on caspar cg 2.3.0. So I think the error is clearly not inside the template.

Solved the problem by installing the latest version of Caspar. But if someone knows the solution for caspar cg 2.0.7, then please write. Since the new version of caspar only works on open gl 4.5, but not all video adapters support this version. I think in any case it will be useful to someone.

I expect that loopic is using some relatively recent javascript features, that are not compatible with the 2014 version of chromium used in 2.0.7.
A lot has changed in the javascript/html world over the last 8 years, and trying to make loopic work the same in both is likely not worth the large amount of time/effort it would take.

3 Likes

I agree to what @Julusian said. It needs quite a few hacks to get a HTML template to run on 2.0.7 as much has changed. If I were you, I would stick with version 2.3.x as this supports a rescent set of features. Or you need to learn to hand code templates to make them work on the old platform.

2 Likes
Privacy Policy   Terms of Service