Problem with a video

Hi all.
I recorded a video with my phone, and tried to play it on casparcg but as soon as the server tries to create a thumbnail it crashes.

Anyone been through this?
Im using version CasparCG 2.1.0 Beta 2 on Ubuntu 16.04.

Does it play with VLC?

Yeah, VLC, ffplay…

Ill get the error message to append here, just a sec.

thats the picture with the error message. It only happens with the video recorded from my phone (galaxy note 8)

Have you checked your videofile with Mediainfo? If you tries to output the file as 1080i5994 can it be some problem with a)progressive framerate b) variable framerate. I know that we have tested phones (1080i50) that not even with FilmicPro you could produce a stable interlaced framerate.
One way to try to solve it is to convert the video (with for example VLC) and see if that helps.

br markus

1 Like

Thanks for the reply Markus, yeah I simply did ffmpeg -i moviefile.mp4 converted.mp4 and the file played smootlhy, but I am more concerned that the server crashes, is there any way I can survive to errors like this? I mean, if I somehow detect that the video is crapy and all and alert the user…

Have you tried in other versions of caspar? 2.1NRK and 2.2 would both be worth a try.

It looks like the file is not exposing the framerate in a way that caspar understands, so it is trying to divide by 0 causing it to crash.

It should be really really easy to guard against that and simply fail to play the clip instead of crashing.
If you could send me the file (wetransfer/google drive link is probably easiest. feel free to pm) then I can have a look at that. I suspect that fixing it so the file will play will be a lot harder, but it may not be.

1 Like

Sorry but the best way of dealing with videofile made by a phone is to convert or take edit them a videoedit-program. A couple of years ago we had a file from a Iphone edited with iMovie and Caspar played it out up-side down

1 Like

Hey guys thanks for the help.

I build version 2.2.0 and made a test and the video player smoothly and with no errors at all. I think Ill stick with this version since it seems to be more stable.

Julusian please let me know if you want the faulty sample that’ll upload for you.

Thats good to hear it works in 2.2.

Yes, it would still be good to get a copy of the file, as I know some people who are still using 2.1 so it would be good to have a fix for that potential crash

Hi Julusian, sorry for the delay.

Here’s the faulty sample.