Poor rendering fonts in HTML template

Hi, I am new in CasparCG.
I’m looking for a new graphics platform for On Air graphics for our TV and CasparCG seems to be a great solution.
I have installed the latest version 2.2.0 Stable and have made some simple HTML template where I found out a problem with a poor rendering of the fonts.
Every round contours are very serrated. I’m looking for some solutions here in the forum and across the web too, but nothing helped.

I’ll be grateful for any tip.

Is font smoothing activated in the Windows settings? Are the templates in the size of the output channel?

I have tryied to activate font smoothing, but the difference was slight, maybe unobservable.
What do you mean by the template size? Width and height parameters of the “body” section of the html code?
The serrated round contours looks identical in the Chrome and Firefox browsers and in the Caspar HDMI output via Blackmagic DeclLink Mini Monitor 4K to FullHD TV.

Yes, they should be 1920x1080 pixels for HD 1080 or 1280x720 for HD 720

When I have restarted the Caspar server, the result look much better!
Is there some settings on the nvidia controla panel (quadro P4000) that might affect this issue?

Probably, I don’t know.

This could depend on the font file - are you using TTF, WOFF etc? Also there are CSS properties to control font rendering like font-smooth. If you are using any kind of transforms that could be an issue.

The serrated contours looks the same at TTF and OTF fonts in very very simple HTML temlate without any animation etc. Tested on Firefox, Chrome and CasparCG.
I have made some fiddling with many CSS properties about smoothing and antialiasing without any effect.
Smoothing activation in Windows has resolved the problem.
Thanks to didikunz.

Sorry, for post revoke, but maybe you could help guys. I’m working with NRK release in 1080i50 with GV mixer. And there is a problem with fonts, maybe you know where is the problem with this kind of template ant font rendering? There is one frame difference between frames in the pictures.

This is a HTML template, right? For HTML you should enable font smoothing in Windows, while for Flash you should disable it.

1 Like

Correct. It’s HTML, i’m using ttf fonts, font smoothing is enabled. I can upload raw video.

https://we.tl/t-BTZSStsD5h Raw video.

Or maybe is it possible somehow to make channel render on 50p for caspar and then do output for bm decklink on 50i?