Pass trough Embedded Audio

Hello,

we are currently using 1 Decklink Recorder to SDI in and play everything out to an Decklink Monitor. We would like to byass the embedded Audio from the Recorder to the Monitor.

Could anyone please leave a message how to change the config?

Thanks a lot
Thomas

If the SDI in is being played on channel 1, layer 10:
MIXER 1-10 VOLUME 0

Thanks a lot for the Feedback!

We made it work but now we have the issue, that the embedded comes with 4 Audio-Channels.

Currently only 2 Channels arrive at the output. I guess we have to add more infomation to the Channels that it should bypassing all Audio Channels.

This is what we have in the Config

  <channels>
    <channel>
        <video-mode>1080i5000</video-mode>
        <consumers>
    	    <decklink>
                <device>1</device>
                <embedded-audio>true [true|false]</embedded-audio>
                <channel-layout>smpte</channel-layout>
                <latency>normal [normal|low|default]</latency>
                <!--key-only>false [true|false]</key-only-->
                <keyer>internal</keyer>
                <buffer-depth>0 [1..]</buffer-depth>
                <custom-allocator>true [true|false]</custom-allocator>
            </decklink>
          <system-audio />
        </consumers>
    </channel>
  </channels>

And this is what we send via ACMP
CLEAR 1
ADD 1 DECKLINK 2
MIXER 1-3 FILL 0 0 1 1
CG 1-3 ADD 10 “WettStar2020_Plaza/cframe” 1
MIXER 1-2 FILL 0 0 1 1
Play 1-2 decklink 1

Any suggestions please?

First of all: Your config is containing trash. Everything between [ and ] needs to be removed. Do that and try again and then report back.

Ok, I will do that. I thought that this would be ignored by the Server.
I will provide more as soon I got something.

I think so also, but it does not make sense to investigate a problem if we are not sure to have the config right in the first place.

You can use this utility to check your casparcg config files: https://casparcg.net/validator/

Wow, that is a cool feature.

I cleaned up everything, but noticed, that our Server 2.0.7 does´nt support 8ch or anything else than stereo, smpte or passthru, which is not valide.

ERROR! The value passthru for channel-layout is invalid. Possible values are: mono|stereo|matrix|film|smpte|ebu_r123_8a|ebu_r123_8b|8ch|16ch

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
    <media-path>media\</media-path>
    <log-path>log\</log-path>
    <data-path>data\</data-path>
    <template-path>templates\</template-path>
    <thumbnails-path>thumbnails\</thumbnails-path>
  </paths>

  <channels>
    <channel>
        <video-mode>1080i5000</video-mode>
        <consumers>
		  <decklink>
                <device>1</device>
                <embedded-audio>true</embedded-audio>
                <channel-layout>smpte</channel-layout>
                <latency>low</latency>
                <keyer>default</keyer>
                <buffer-depth>1</buffer-depth>
                <custom-allocator>true</custom-allocator>
            </decklink>
          <system-audio />
        </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
        <port>5250</port>
        <protocol>AMCP</protocol>
    </tcp>
  </controllers>
</configuration>

Apart from that should passthru do the job, I guess, but at the output we only have 2 audio-channels.

So I believe, that we maybe have to send more code via ACMP tha ensure, that Input AND Output will take care/forward the embedded audio completly including all channels.

So what else could we try?

Thanks a lot
Cheers Thomas

I believe the channel audio format needs to be 16ch for pasthrough, and then you need to start the decklink producer as 16ch as well by using CHANNEL_LAYOUT 16ch in the AMCP command.

If you use the latest 2.3 Release Candidate you’ll get 8 channel audio by default, I believe.

Have you tried to set embedded audio to false and the keyer to internal? Probably that does the job. You sure will loose the possibility to have audio from Caspar, but that is not a problem when you only do graphics.

Hi Didi,
I really hope this works. :wink:
Our next production is tomorrow and the client is a bit unhappy, cause we only provide 2 channels.
I am currently 400km away from the place, where the production takes place and it is always hard to feel unable to help.
We only need the AudioEmbedded and of course graphics and no extra audio.
But to be honest, why should it work???

I just was thinking, that if you do not touch the embedded audio, by setting it to false, it could be, that it just let it pass trough without doing anything to it. I have no source with embedded audio, so I cannot test it for you.

Ah, ok. I thought this is part of your experience. :wink:
For now I have changed the config.
I also have the Code how to setup the Channel-Layout. Maybe one of this helps.
I will let you know.
Thanks so far.

Hahaha, no, not much experience in that. I very seldom use internal keying. I do it the “right and proper way” using fill & key and sending that to a vision mixer :slight_smile:

By the way: Changed the title of the tread to reflect what we are actually talking about.

That surely won’t work on a decklink recorder + monitor combo since internal keying is a hardware feature

You are right. In that case I see no way except using hardware embedder deembedder combo.

Hi Guys,

unfortunately in Munich the System is having a Decklink Duo. So all on one card.
Setting the Keyer to internal and AudioEmbedded to false makes the Server unavailable for Connections. So I guess there is something wrong.
Switching Audio Embedded back to True but keeping Keyer on Internal brings the same result.
So I had to reset it to make sure at least the current status is fine.

Maybe it could be enough to send this in the console!?

SET 1 CHANNEL_LAYOUT 16ch

Is it an old Duo or the new Duo 2?

Honstly I don´t know. :innocent:
The ControlCenter says nothing special. In the DesktopVideoApp I only see SDI 1 und SDI2.
Any idea where I could find info about the version of card?

The utility should show the product image. If it has a cooler it’s the Duo 2, otherwise it’s a Duo.

Privacy Policy   Terms of Service