No video from decklink on system startup

Hi, I hope it’s ok to post this here since it is not strictly a CasparCG issue, but since there’s a lot of Decklink users here I wonder if anyone else has experienced this.

When I start up the PC (win 10), I can get no output from CasparCG. The server doesn’t throw any errors but there’s no video on decklink consumer or screen consumer. I then have to restart the server to get video, and after that everything seems to be ok. I’m using CasparLauncher by rrebuffo and server version 2.3.3. Decklink duo 2 and duo 2 mini both have this issue, 8k pro works fine.

Same thing happens with Davinci Resolve. No video after first boot, but after restarting the software everything works. BMD support has been contacted but I figured I’d try my luck here also. Thanks!

Does CasparCG autostart with Windows? If yes, what happens, when you disable autostart and manually start it, when Windows is fully loaded?

Yes, I also observed this problem.

I’ve noticed same problem, on some smaller PC’s with less PCIe bandwidth. (24 lanes)
Somehow it looks like the motherboard starts up in lower PCIe v1.0 version (instead of PVIe v3.0) and when restarting the machine it will run at full speed.

I did this hack (AND it IS a hack) When swapping position of the GPU card and the Decklink card, the Decklink card will be in the first PCIe connecter, and this one will always be full PCIe speed.
I have only done that on machines that was mainly used for playout (no html etc.)

It looks like that negotiation og the Decklink card and PCIe happens before the Decklink is running, or something like that.
(I’m not an expert, so this was just my own conclusions)

Hope you solve the problem, and please report back here if you do some findings, as i’m still looking for at real solution :slight_smile:

Doesn’t make a difference. The behavior is fairly consistent, sometimes (rarely) the PC surprises me and works the first time, but when I do several boot cycles in a row it certainly seems like the the decklink doesn’t wake up with the rest of the system.

Lol that is a hack indeed. I tried changing some bios settings like disabling fast boot, automatic PCI power management and clock gating but none of it had any effect. Will report here if I manage to figure out a solution

Privacy Policy   Terms of Service