New Version: Video playback is jerky, old version runs smoothly

I am experimenting with version 2.3.3 and now the playback of QT with transparency is running jerky. With version 2.0.7 it runs smoothly. I am using a RTX 3070 but the older version even ran without the card. One problem could be that I use the graphic card with a riser on a short PCIe slot. I needed the long one for the Decklink.

But the card does get 16 PCIe lanes, does it?

Yes. The Riser connects x16 to x1. I tried a Geeks3D FurMark stress test without problems.

But then the GPU only gets 1 PCIe lane instead of 16. That will not work, regardless of benchmarks :slight_smile:

I am just confused because the older version makes no problems. Does it use the graphic card less?

I don’t really know. AFAIK 2.0.7 uses the GPU only for the mixer effects, while FFMPEG uses the CPU only. Maybe newer FFMPEG versions also use the GPU, but to have an exact answer, somebody of the core developers would need to tell.

I usually always configure my systems so, that both, the Decklink and the GPU can have the full amount of PCIe lanes, they demand. That has always worked.


If you are using interlaced signals then version 2.3 can use double the GPU processing because it uses an internal progressive flow. Thus 50 fields per second becomes 50 frames per second, with the consumer re-building the interlace output, similarly for 59.94 fields being processed as 59.94 frames.

I am using acutally 1080 50p. But I thought that a RTX3070 should get that when the older version makes it with the cheap onboard graphic without problems…

If it gets it’s 16 lanes, it would.

@didikunz is offering very good advice. He has previously posted a link to a very good tool called SiSoftware Sandra (available here) that can test the actual lane speed. The Lite (free) version has the required test capabilities. Some hardware systems have PCIe lane sharing on some routes with the result the bandwidth to the specific PCIe socket is reduced.

1 Like