NDI4 problem


#1

HI
Run today into a strange problem
Let start with my setup
Caspar 2.3 dev build from 2019-11-12 on a laptop.
NDI 4 runtime installed and “Processing.NDI.lib.x64.dll” copied to server folder
in my config i have

<ndi>
<name>CasparCG 1</name>
<allow-fields>False</allow-fields>
</ndi>

Now to the interresting part
when I run “play 1-10 go1080p25 loop” it runs at it should on the same computers Newtek StudioMonitor (NDI Tools 4)
BUT
when I try to open it on another computer in the network it shows up as a source but it wont show any video.
Tried with the same laptop on 2 different networks to both different Tricasters (with NDI 4 update) and Studio Monitor.
When I run a CasparCG 2.2 in the networks to the same destinations it shows with no sound (as it is expected)
Testpatterns are showing correctly so it should be a NDI-network-problem because everthing else but CasparCG is working as it is expected.
Has anyone got CasparCG to work with NDI4?
And is there something Im missing?


#2

Disable windows firewall


#3

Most likely right.
On my desktop computers dev build 2019-11-12 to Stdio monitor runs OK.
Hate company laptops.
Probably a “allow application” problem.
Thanks