NDI Studio monitor mute

playout
ndi

#1

Hi
Has anyone else got the problem that NDI out from CasparCG is mute in Newtek StudioMonitor but has sound in vMix (as NDI Input)?
Noticed the same in both 2.0.7 & 2.2.0
Heres my 2.2.0 config

> 
> <?xml version="1.0" encoding="UTF-8"?>
> <configuration>
>   <log-level>info</log-level>
>   <paths>
>     <media-path>D:\_media/</media-path>
>     <log-path>log/</log-path>
>     <data-path>data/</data-path>
>     <template-path>D:\_template/</template-path>
>   </paths>
>   <lock-clear-phrase>secret</lock-clear-phrase>
>   <channels>
>     <channel>
>       <video-mode>1080i5000</video-mode>
>       <consumers>
>         <newtek-ivga />
>         <decklink>
>           <device>1</device>
>           <key-device>2</key-device>
>           <embedded-audio>true</embedded-audio>
>           <latency>normal</latency>
>           <keyer>external</keyer>
>           <key-only>false</key-only>
>           <buffer-depth>3</buffer-depth>
>         </decklink>
>  <system-audio />
>       </consumers>
>     </channel>
>     <channel>
>       <video-mode>1080i5000</video-mode>
>       <consumers>
>         <newtek-ivga />
>         <decklink>
>           <device>2</device>
>           <key-device>2</key-device>
>           <embedded-audio>true</embedded-audio>
>           <latency>normal</latency>
>           <keyer>external</keyer>
>           <key-only>false</key-only>
>           <buffer-depth>3</buffer-depth>
>         </decklink>
>       </consumers>
>     </channel>
>     <channel>
>       <video-mode>1080i5000</video-mode>
>       <consumers>
>         <decklink>
>           <device>3</device>
>           <key-device>2</key-device>
>           <embedded-audio>true</embedded-audio>
>           <latency>normal</latency>
>           <keyer>external</keyer>
>           <key-only>false</key-only>
>           <buffer-depth>3</buffer-depth>
>         </decklink>
>       </consumers>
>     </channel>
>     <channel>
>       <video-mode>1080p2500</video-mode>
>       <consumers>
>         <decklink>
>           <device>4</device>
>           <key-device>2</key-device>
>           <embedded-audio>true</embedded-audio>
>           <latency>normal</latency>
>           <keyer>external</keyer>
>           <key-only>false</key-only>
>           <buffer-depth>3</buffer-depth>
>         </decklink>
>       </consumers>
>     </channel>
>   </channels>
>   <controllers>
>     <tcp>
>       <port>5250</port>
>       <protocol>AMCP</protocol>
>     </tcp>
>   </controllers>
>   <amcp>
>     <media-server>
>       <host>localhost</host>
>       <port>8000</port>
>     </media-server>
>   </amcp>
>   <flash>
>     <buffer-depth>auto</buffer-depth>
>   </flash>
>   <html>
>     <remote-debugging-port>0</remote-debugging-port>
>     <enable-gpu>false</enable-gpu>
>   </html>
>   <ndi>
>     <auto-load>true</auto-load>
>   </ndi>
>   <osc>
>     <default-port>6250</default-port>
>     <disable-send-to-amcp-clients>false</disable-send-to-amcp-clients>
>     <predefined-clients>
>       <predefined-client>
>         <address>127.0.0.1</address>
>         <port>5253</port>
>       </predefined-client>
>     </predefined-clients>
>   </osc>
> </configuration>

In StudioMonitor the VU-meter does not show which to me indicates that the StudioMonitor dont recive any audio, aka it is not a PC-monitoring-problem.


#2

Happened to me that NDI was not playing any audio, neither in Studio Monitor or OBS. Had to switch back to iVGA.
Have you tried to change volume level in the options? It is muted by default.


#3

I also have the same issue with @Julusian’s NDI branch of 2.1.x NRK. Studio Monitor plays no audio but OBS does. But this happens only on my PC.

At work I have the same server version: Studio Monitor and OBS does play the audio.


#4

It is not the settings, The studio monitor plays for example out sound from a VLC-source, as said it shouldnt be Caspar since vMix plays out the sound.
It is not a network issue since the same thing is reproduced on the casparcg machine and on a vmix in the same network.
Both have NDI 4 installed, can that be the issue? vMix 22 doesnt use NDI4 but 3.8.
I think I have to install 3.8 on some machine and see if that is the reason.