NDI Doesnt work any server and any pc

template
server

#1

Hi!

I have a problem with NDI output, i try on two pc with all versions of casparcg server; i put the Air Send Dll’s, try with diferent casparcg clients, and doesnt work. I cant see the NDI Output in my tricaster neither video monitor.

Can you help me?

The only think that the console says is

[2018-09-10 13:28:45.959] [6732] [info]    ############################################################################
[2018-09-10 13:28:45.961] [6732] [info]    CasparCG Server is distributed by the Swedish Broadcasting Corporation (SVT)
[2018-09-10 13:28:45.961] [6732] [info]    under the GNU General Public License GPLv3 or higher.
[2018-09-10 13:28:45.961] [6732] [info]    Please see LICENSE.TXT for details.
[2018-09-10 13:28:45.961] [6732] [info]    http://www.casparcg.com/
[2018-09-10 13:28:45.961] [6732] [info]    ############################################################################
[2018-09-10 13:28:45.961] [6732] [info]    Starting CasparCG Video and Graphics Playout Server 2.1.0.3437 dc2e94b Beta 2
[2018-09-10 13:28:45.961] [6732] [info]    on Windows 10 Home Single Language
[2018-09-10 13:28:45.961] [6732] [info]    AMD A10-7300 Radeon R6, 10 Compute Cores 4C+6G  Physical Threads: 4
[2018-09-10 13:28:45.961] [6732] [info]    80DW
[2018-09-10 13:28:45.962] [6732] [info]    Initialized reroute module.
[2018-09-10 13:28:45.968] [6732] [info]    Initialized ffmpeg module.
[2018-09-10 13:28:45.968] [6732] [info]    Initialized oal module.
[2018-09-10 13:28:46.783] [6732] [info]    Initialized bluefish module.
[2018-09-10 13:28:46.783] [6732] [info]    Initialized decklink module.
[2018-09-10 13:28:46.784] [6732] [info]    Initialized screen module.
[2018-09-10 13:28:48.781] [6732] [info]    Initialized html module.
[2018-09-10 13:28:48.781] [6732] [info]    Initialized psd module.
[2018-09-10 13:28:51.162] [6732] [info]    Initialized flash module.
[2018-09-10 13:28:51.162] [6732] [info]    Initialized newtek module.
[2018-09-10 13:28:51.163] [6732] [info]    Initialized image module.
[2018-09-10 13:28:51.284] [6732] [info]    Loaded C:\Windows\SYSTEM32\Processing.AirSend.x64.dll
[2018-09-10 13:28:51.284] [6732] [info]    ffmpeg.avcodec 56.41.100
[2018-09-10 13:28:51.284] [6732] [info]    ffmpeg.avformat 56.36.100
[2018-09-10 13:28:51.284] [6732] [info]    ffmpeg.avfilter 5.16.101
[2018-09-10 13:28:51.284] [6732] [info]    ffmpeg.avutil 54.27.100
[2018-09-10 13:28:51.284] [6732] [info]    ffmpeg.swscale 3.1.101
[2018-09-10 13:28:51.284] [6732] [info]    bluefish.version Not found
[2018-09-10 13:28:51.284] [6732] [info]    decklink.version 10.10
[2018-09-10 13:28:51.284] [6732] [info]    cef.version 3.1750.1805
[2018-09-10 13:28:51.285] [6732] [info]    cef.chromeversion 33.0.1750.170
[2018-09-10 13:28:51.285] [6732] [info]    flash 18.0.0.203
[2018-09-10 13:28:51.285] [6732] [info]    newtek-ivga.version available
[2018-09-10 13:28:51.285] [6732] [info]    freeimage 3.16.0
[2018-09-10 13:28:51.285] [6732] [info]    casparcg.config:
[2018-09-10 13:28:51.285] [6732] [info]    -----------------------------------------
[2018-09-10 13:28:51.285] [6732] [info]    <?xml version="1.0" encoding="utf-8"?>
[2018-09-10 13:28:51.285] [6732] [info]    <configuration>
[2018-09-10 13:28:51.285] [6732] [info]       <paths>
[2018-09-10 13:28:51.285] [6732] [info]          <media-path>media/</media-path>
[2018-09-10 13:28:51.285] [6732] [info]          <log-path>log/</log-path>
[2018-09-10 13:28:51.285] [6732] [info]          <data-path>data/</data-path>
[2018-09-10 13:28:51.285] [6732] [info]          <template-path>template/</template-path>
[2018-09-10 13:28:51.285] [6732] [info]          <thumbnail-path>thumbnail/</thumbnail-path>
[2018-09-10 13:28:51.285] [6732] [info]          <font-path>font/</font-path>
[2018-09-10 13:28:51.285] [6732] [info]       </paths>
[2018-09-10 13:28:51.285] [6732] [info]       <lock-clear-phrase>secret</lock-clear-phrase>
[2018-09-10 13:28:51.285] [6732] [info]       <channels>
[2018-09-10 13:28:51.285] [6732] [info]          <channel>
[2018-09-10 13:28:51.285] [6732] [info]             <video-mode>NTSC</video-mode>
[2018-09-10 13:28:51.285] [6732] [info]             <channel-layout>stereo</channel-layout>
[2018-09-10 13:28:51.285] [6732] [info]             <consumers>
[2018-09-10 13:28:51.285] [6732] [info]                <newtek-ivga>
[2018-09-10 13:28:51.285] [6732] [info]                   <channel-layout>stereo</channel-layout>
[2018-09-10 13:28:51.285] [6732] [info]                   <provide-sync>true</provide-sync>
[2018-09-10 13:28:51.285] [6732] [info]                </newtek-ivga>
[2018-09-10 13:28:51.285] [6732] [info]             </consumers>
[2018-09-10 13:28:51.285] [6732] [info]          </channel>
[2018-09-10 13:28:51.285] [6732] [info]       </channels>
[2018-09-10 13:28:51.285] [6732] [info]       <controllers>
[2018-09-10 13:28:51.285] [6732] [info]          <tcp>
[2018-09-10 13:28:51.285] [6732] [info]             <port>5250</port>
[2018-09-10 13:28:51.285] [6732] [info]             <protocol>AMCP</protocol>
[2018-09-10 13:28:51.285] [6732] [info]          </tcp>
[2018-09-10 13:28:51.285] [6732] [info]          <tcp>
[2018-09-10 13:28:51.285] [6732] [info]             <port>3250</port>
[2018-09-10 13:28:51.285] [6732] [info]             <protocol>LOG</protocol>
[2018-09-10 13:28:51.285] [6732] [info]          </tcp>
[2018-09-10 13:28:51.285] [6732] [info]       </controllers>
[2018-09-10 13:28:51.285] [6732] [info]    </configuration>
[2018-09-10 13:28:51.285] [6732] [info]    -----------------------------------------
[2018-09-10 13:28:51.287] [6732] [info]    Initialized audio config.
[2018-09-10 13:28:51.287] [6732] [info]    Initializing OpenGL Device.
[2018-09-10 13:28:52.231] [6732] [info]    Successfully initialized OpenGL 4.5.13506 Compatibility Profile Context 23.20.15017.3010 ATI Technologies Inc.
[2018-09-10 13:28:52.237] [6732] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 1
[2018-09-10 13:28:52.238] [6732] [info]    video_channel[1|NTSC] Successfully Initialized.
[2018-09-10 13:28:52.239] [6732] [warning] Assertion Failed: air_send_ file:modules\newtek\consumer\newtek_ivga_consumer.cpp line:104
[2018-09-10 13:28:52.239] [6732] [info]    newtek-ivga[not connected] Initialized.
[2018-09-10 13:28:52.239] [6732] [info]    Initialized channels.
[2018-09-10 13:28:52.239] [6732] [info]    Initialized OpenGL Accelerated GPU Image Mixer for channel 0
[2018-09-10 13:28:52.243] [6732] [info]    Initialized thumbnail generator.
[2018-09-10 13:28:52.245] [6732] [info]    Initialized controllers.
[2018-09-10 13:28:52.245] [6732] [info]    Initialized osc.

29:06.022] [13700] [info]    [frame_muxer] simple 1920x1080p25.00
[2018-09-10 13:29:06.046] [13700] [warning] ffmpeg[AMB.mp4|1920x1080p25.00|1/268] Frame blending frame rate conversion required to conform to channel frame rate.
[2018-09-10 13:29:06.201] [284]   [warning] [buffer] Performance warning. Buffer mapping blocked: 0.025
[2018-09-10 13:29:06.400] [284]   [warning] [buffer] Performance warning. Buffer mapping blocked: 0.021

#2

I try with:
MSI GT72VR - 1060 NVIDIA - Windows 10 pro PC 64 bit
Lenovo AMD Windows 10 home 64bit PC

servers:
2.0.7
2.1.0 beta 2
2.2.0 beta7


#3

Does it work locally? Using vMix or NDI Tools’ Studio Monitor?
Have you tried turning off Windows’ Firewall?


#4

This line in the log implies that caspar failed to intiialize a ndi stream properly.
Have you tried some other resolutions?
And have you checked that your machines meet the minimum requirements for ndi? Perhaps some cpu features it needs arent supported by your amd cpu?
It is managing to load the plugin though and with the little logging it does it is hard to tell what the problem could be


#5

Solved

I put the Processing.AirSend.x64.dll and Processing.AirSend.x86.dll directly on the server folder and now it works.

Thanks all.