Live video input from BlackMagic Card as CasparCG layer


#1

“The Decklink producer allows video sources to be input from BlackMagic Design cards and used as CasparCG Server layers so that CasparCG Server’s Mixer can then be used to manipulate the layer.”

I would like to use a live video that’s being inputed through the BlackMagic card as a video layer. I would like to use the Mixer to manipulate that video layer (resize, position, etc.). When I put internal keyer in the configuration I can see the video, but it is in the background and I cannot do anything with it. I assume the keyer has to be external. In this mode the video is not in the background. How can I get it (and show it) through a certain layer?

Can anyone help me with this?

Thank you.


#2

With keyer external simply send the following command

PLAY 1-10 DECKLINK DEVICE 2 FORMAT 1080i5000

where the 2 after device is the card number (normally count from the bottom off the card)

You need to have 2 cards for this or a card that can act as input and output at the same time.
only a few BM cards can do that.


#3

Thank you, Maurice. Could you, please, indicate which BM cards can do that?


#4

With Decklink Duo 2 and Quad 2 you can use both internal keyer and the input as a layer in CasparCG.


#5

I try to explain this as simple as possible.
When you configure your decklink-card in the CasparCG config-file you have to leave on Decklink-channel unused if you want to use it as a Input. The reason is that in the config-file your define your Output-channels and the reserve those as Outputs and Decklink-channels can just be In- OR Outputs not both.
I usually dont use in config-file Decklink device 1 for a input instead I use Device 2 or 3 for the output of channel 1 (depending on Decklink-card).
If you are using the SVT default client there is in Tools/other “Decklink Input”, drag that to your rundown and in the right hand panel start to fill in Input Ex Server=local, channel 1, layer 10, The comes the more important Decklink Input-section.
In Device you set the Decklink that isnt configured as an output
In Format set the right resolution or no video will show
the rest you can forget
So now you have configured it, next you need to test this
To test you need a videosource that you know what resolution it give out and a monitor.
The test starts by checking that your output is OK, so Play a video on Caspar Channel 1 and confirm that it is playing in the monitor.
When that step is done the we move to checking the input. So connect your Source to decklink and start playing the input on the same channel that you just used for playout. What this do is that the client is sending the command that Maurice78 wrote to the server.
To do this you need a decklink-card that has at least 2 channels, I uses nowadays almost just Duo2. This is my config-file for doing one channel Fill-key, one just Fill and one Input

<?xml version="1.0" encoding="utf-8"?> D:\_media/ log/ data/ D:\_templates/ d:\_thumbnails/ D:\_fonts/

secret

1080i5000 false stereo true 2 true stereo normal external false 3 true 1080i5000 false stereo true 3 true stereo normal default false 3 true 6250 false 127.0.0.1 5253 5250 AMCP localhost 8000

And this is my guide for my user concerning the Decklink-setup

Decklink Duo2 configured as 1 graphicschannel(Fill+Key) + 1 storychannel(Fill) + 1 Inputchannel (device1)
Start with downloading and installing BlackMagic Design Desktop Video setup https://www.blackmagicdesign.com/support/family/capture-and-playback
Restart computer
start Desktop Video Setup
each dot (under the picture) represents BNC, I will call them BMD1, BMD2, BMD3 and BMD4.
Choose BMD1 and press the edit-icon. On the first “Video Output”-sheet select your working resolution and on the “Connectors”-sheet select “SDI 1”
Choose BMD2 and press the edit-icon. On the “Video Output”-sheet select your working resolution and on the “Connectors”-sheet select “SDI 3&SDI 4”.
Choose BMD3 and press the edit-icon. On the “Video Output”-sheet select your working resolution and on the “Connectors”-sheet select “SDI 2”
ChooseBMD4 and press the edit-icon. On the “Video Output”-sheet select your working resolution and on the “Connectors”-sheet confirm that there is “none”
With the config-file below this will give you the following output (from left to right) ref - SDI IN - Channel 2 Fill Out - Channel 1 Key out - Channel 1 Fill out

Sorry for a long explainer


#6

Sorry the config file didint paste properly

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <paths>
    <media-path>D:\_media/</media-path>
    <log-path>log/</log-path>
    <data-path>data/</data-path>
    <template-path>D:\_templates/</template-path>
    <thumbnail-path>d:\_thumbnails/</thumbnail-path>
    <font-path>D:\_fonts/</font-path>
  </paths>

  <lock-clear-phrase>secret</lock-clear-phrase>

  <channels>
     <channel>
		<video-mode>1080i5000</video-mode>
		<straight-alpha-output>false</straight-alpha-output>
	<consumers>
		 <newtek-ivga>
              		<channel-layout>stereo</channel-layout>
              		<provide-sync>true</provide-sync>
            	</newtek-ivga>
		<decklink>
			<device>2</device>
			<embedded-audio>true</embedded-audio>
			<channel-layout>stereo</channel-layout>
			<latency>normal</latency>
			<keyer>external</keyer>
			<key-only>false</key-only>
			<buffer-depth>3</buffer-depth>
			<custom-allocator>true</custom-allocator>
		</decklink>            
	</consumers>
    </channel>
    <channel>
		<video-mode>1080i5000</video-mode>
		<straight-alpha-output>false</straight-alpha-output>
	<consumers>
 		<newtek-ivga>
              		<channel-layout>stereo</channel-layout>
              		<provide-sync>true</provide-sync>
            	</newtek-ivga>
		<decklink>
			<device>3</device>
			<embedded-audio>true</embedded-audio>
			<channel-layout>stereo</channel-layout>
			<latency>normal</latency>
			<keyer>default</keyer>
			<key-only>false</key-only>
			<buffer-depth>3</buffer-depth>
			<custom-allocator>true</custom-allocator>
		</decklink>
	</consumers>
    </channel>
    </channels>
 
<osc>
  <default-port>6250</default-port>
  <disable-send-to-amcp-clients>false</disable-send-to-amcp-clients>
  <predefined-clients>
    <predefined-client>
      <address>127.0.0.1</address>
      <port>5253</port>
    </predefined-client>
  </predefined-clients>
</osc>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>localhost</host>
      <port>8000</port>
    </media-server>
  </amcp>
</configuration>



#7

Thank you very much for the detailed instructions, Markus.

Instead of using two video cards I opted for one video card for input and screen consumer as an output, so now I rely on my graphic card for the output. I don’t know if that is a good choice, but I’ll find out soon enough.


#8

In a studio environment, where you have everything in SDI that is a bad idea, as the desktop (GPU output) is normally not compatible. The better solution would be to buy a Decklink Duo 2. Chaep card with many possibilities.


#9

Eventually, I decided to buy that card. Thank you for the advice.