Latency: 0 issue

I keep getting latency problems with a particular video. Parts of the video play OK, other parts become very laggy and the console shows a latency: 0 problem. Also the Diagnostics screen shows “Underflow” issue? Any ideas what could be causing this?

My Configuration file:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <log-level>debug</log-level>
  <paths>
    <media-path>D:\Media</media-path>
    <log-path>D:\Log</log-path>
    <data-path>D:\Data</data-path>
    <font-path>C:\Windows\Fonts</font-path>
    <template-path>D:\Templates</template-path>
  </paths>
  <lock-clear-phrase>secret</lock-clear-phrase>
  <channels>
    <channel>
      <video-mode>1080i5994</video-mode>
      <consumers>
        <decklink>
          <device>1</device>
          <key-device>0</key-device>
          <embedded-audio>true</embedded-audio>
          <latency>normal</latency>
          <keyer>default</keyer>
          <key-only>false</key-only>
          <buffer-depth>3</buffer-depth>
        </decklink>
      </consumers>
    </channel>
    <channel>
      <video-mode>1080i5994</video-mode>
      <consumers>
        <ndi>
          <name>ndi</name>
          <allow-fields>true</allow-fields>
        </ndi>
      </consumers>
    </channel>
  </channels>
  <controllers>
    <tcp>
      <port>5250</port>
      <protocol>AMCP</protocol>
    </tcp>
  </controllers>
  <amcp>
    <media-server>
      <host>10.105.197.172</host>
      <port>8000</port>
    </media-server>
  </amcp>
  <flash>
    <buffer-depth>6</buffer-depth>
    <enabled>true</enabled>
  </flash>
  <html>
    <remote-debugging-port>0</remote-debugging-port>
    <enable-gpu>true</enable-gpu>
  </html>
  <ffmpeg>
    <producer>
      <auto-deinterlace>interlaced</auto-deinterlace>
      <threads>4</threads>
    </producer>
  </ffmpeg>
  <ndi>
    <auto-load>true</auto-load>
  </ndi>
  <osc>
    <default-port>6250</default-port>
    <disable-send-to-amcp-clients>false</disable-send-to-amcp-clients>
    <predefined-clients>
      <predefined-client>
        <address>10.105.197.172</address>
        <port>5253</port>
      </predefined-client>
    </predefined-clients>
  </osc>
</configuration>

SOLVED. It turnes out to be an old HDD that was not able to keep up with CasparCG reads from the Media folder. Swapped the HDD for an Samsung 860Pro SSD and it that solved the issues.

Privacy Policy   Terms of Service