KB4577586 that’s the end?

After this update was installed - no more flash player and no chance to install it once again. Any solutions?

Even CfgWriter is useless…

I access many pcs these days with this problem, manually putting flash.ocx and mms.cfg files, registering with regsvr32 and flash started working.I may help trying it on anydesk remote.

Can you share a syntax of how to register?

cmd run as administrator

regsvr32 "C:\Program Files (x86)\Doordarshan\CasparMediaPlaybackSetup\flash.ocx"
regsvr32 "C:\Windows\System32\Macromed\Flash\flash.ocx"
regsvr32 "C:\Windows\SysWOW64\Macromed\Flash\flash.ocx"
1 Like

Thank you! It works! I don’t know how long it last, but right now it works!

1 Like

Here you find a tool, that helps with the installation and registering.


Hi, for reference if anyone want to update windows.
I just apply the hotfix for flash before updating windows, everything fine, than update windows along with the “flash removal update”, of course not working anymore, than reinstalled flash and do the registering and everything works fine again.
I did this the first time on a Intel tablet that I use for testing and then on the NUC for production.
Seams pretty safe to update, of course I recommend always do a full disk backup like Acronis or similar, just in case.

Tanks a lot to everyone involved in the Flash Hotfix

1 Like

Hello to all.

Didikunz’s little tools are life savers,thanks a lot for that. Had the same issue with this update and installer and patcher worked great,after the last update flash is still working on casparcg hotfix builds.

Also I would like to ask something that maybe is quite silly but is just a thought. Adobe Animate has the option to publish flash templates into WIN Projectors which is an .exe file that has flash Player embedded in it, so no matter if flash is installed or not in any system and version.this .exe file displays the flash content just like the flash player, could this be a solution I don’t know for a caspar Build maybe? To solve any future issues? As Adobe is not going to stop updating and supporting Flash for use in such applications.

I think, that’s what they call AIR. As an old Flash veteran I would love such a solution emotionally. But looking rational at the topic I think it is not a good idea.

When CasparCG was created, Flash was the dominant technology to create animations for the web. Every organisation, that designed websites had a few Flash experts. So it was easy for them to build templates. Today the dominant technology to create web animations is HTML5 and it is very hard to find Flash experts and will, now after Flash EOL be even harder.

From this view and also from the fact, that all contributors to CasparCG server’s code have a day job, that sometimes overlaps with code contribution and sometimes not. But everyone always needs to ask himself if a feature is worth the effort or not. That is, for instance, the reason, why the PSD producer has been removed and will also be the reason, why the Flash producer one day will be removed (you will still be able to run an older version, of course).

What, in my opinion, would help Caspar much more, would be a environment to create HTML5 templates in a simple way, without knowledge of HTML, CSS and JavaScript. Every other CG out there has such a tool for it’s own template format. And that would probably be worth the effort to create.


Hugely agree with that statement @didikunz . As someone who knows Flash AS pretty well and not HTML, I’ve had to admit its time to learn a new tool.
A lot of the CG people do isn’t that complex so a tool allowing video to run in background and text overlay in a certain position would probably be very useful. I understand from my HTML friends that such a tool isn’t as readily available as it was in Flash. That said, the Lottie process apparently helps.

I wanted to use the new version of the CMP and CasparCG server. I have installed casparcg-server-v2.3.1-lts-stable and the latest CMP version
I use flash graphics. Although everything is properly installed (I think), the Twoliner module does not support flash graphics. Where did I go wrong?

[2021-03-21 12:27:46.445] [info]    Received message from CG 1-66 ADD 66 "cmp/TwoLiner/TwoLiner" 1 "<templateData><componentData id=\"xf0\"><data id=\"text\" value=\"RW5naW5lZXJpbmcgQXNzaXN0YW50LCBEb29yZGFyc2FoYW4gS2VuZHJhLCBNdW1iYWksIEluZGlh\" /></componentData><componentData id=\"f0\"><data id=\"text\" value=\"Engineering Assistant, Doordarsahan Kendra, Mumbai, India\" /></componentData><componentData id=\"xf1\"><data id=\"text\" value=\"UmFtIExhbCBUcmlwYXRoaQ==\" /></componentData><componentData id=\"f1\"><data id=\"text\" value=\"Ram Lal Tripathi\" /></componentData></templateData>"\r\n
[2021-03-21 12:27:46.446] [info]    flash[file:///C:/CasparCG%20Server/template/cg20.fth.1080i5000|0] Initialized
[2021-03-21 12:27:46.448] [error]   Exception: C:\Code\casparcg\official-master\src\modules\flash\producer\flash_producer.cpp(229): Throw in function __cdecl caspar::flash::flash_renderer::flash_renderer(const class caspar::spl::shared_ptr<class caspar::diagnostics::graph> &,const class std::shared_ptr<class caspar::core::frame_factory> &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,int,int)
[2021-03-21 12:27:46.448] [error]   Dynamic exception type: class boost::exception_detail::clone_impl<struct caspar::caspar_exception>
[2021-03-21 12:27:46.448] [error]   [struct caspar::tag_msg_info * __ptr64] = flash-player[cg20.fth.1080i5000|1920x1080] Failed to Create FlashAxControl
[2021-03-21 12:27:46.448] [error]   [struct caspar::tag_stacktrace_info * __ptr64] =  0# 0x00007FF771FA524E in casparcg
[2021-03-21 12:27:46.448] [error]    1# 0x00007FF771FC57C0 in casparcg
[2021-03-21 12:27:46.448] [error]    2# 0x00007FF772133D35 in casparcg
[2021-03-21 12:27:46.448] [error]    3# 0x00007FF772134D66 in casparcg
[2021-03-21 12:27:46.448] [error]    4# 0x00007FF772136FB7 in casparcg
[2021-03-21 12:27:46.448] [error]    5# 0x00007FF772062020 in casparcg
[2021-03-21 12:27:46.448] [error]    6# 0x00007FF77203122E in casparcg
[2021-03-21 12:27:46.448] [error]    7# 0x00007FF77202F2D0 in casparcg
[2021-03-21 12:27:46.448] [error]    8# 0x00007FF771FA1489 in casparcg
[2021-03-21 12:27:46.448] [error]    9# configthreadlocale in ucrtbase
[2021-03-21 12:27:46.448] [error]   10# BaseThreadInitThunk in KERNEL32
[2021-03-21 12:27:46.448] [error]   11# RtlUserThreadStart in ntdll
[2021-03-21 12:27:46.448] [error]
[2021-03-21 12:27:46.448] [error]
[2021-03-21 12:27:46.448] [error]    0# 0x00007FF771FA524E in casparcg
[2021-03-21 12:27:46.448] [error]    1# 0x00007FF771FA4D2F in casparcg
[2021-03-21 12:27:46.448] [error]    2# 0x00007FF77224D709 in casparcg
[2021-03-21 12:27:46.448] [error]    3# 0x00007FFF8B021030 in VCRUNTIME140
[2021-03-21 12:27:46.448] [error]    4# is_exception_typeof in VCRUNTIME140
[2021-03-21 12:27:46.448] [error]    5# RtlCaptureContext2 in ntdll
[2021-03-21 12:27:46.448] [error]    6# 0x00007FF772134D66 in casparcg
[2021-03-21 12:27:46.448] [error]    7# 0x00007FF772136FB7 in casparcg
[2021-03-21 12:27:46.448] [error]    8# 0x00007FF772062020 in casparcg
[2021-03-21 12:27:46.448] [error]    9# 0x00007FF77203122E in casparcg
[2021-03-21 12:27:46.448] [error]   10# 0x00007FF77202F2D0 in casparcg
[2021-03-21 12:27:46.448] [error]   11# 0x00007FF771FA1489 in casparcg
[2021-03-21 12:27:46.448] [error]   12# configthreadlocale in ucrtbase
[2021-03-21 12:27:46.448] [error]   13# BaseThreadInitThunk in KERNEL32
[2021-03-21 12:27:46.448] [error]   14# RtlUserThreadStart in ntdll
[2021-03-21 12:27:46.448] [error]
[2021-03-21 12:27:46.521] [info]    Sent message to CG OK\r\n```

Fixed. It turned out that during various tests and installations there was a big mess in the directories:


After cleaning up and leaving the correct files in the correct versions, everything started working. It’s worth being persistent :wink:

1 Like