Issue with graphics sliding in vertical tearing

graphics

#1

I’ve been doing some testing with sliding graphics in from the left and I’ve noticed that they are blurry while sliding in, I’m using Tumult Hype3 to generate HTML graphics.

If I set the channel to 1080i50 I get vertical tearing, if I use 1080p50 it all works fine.

1080i5000

1080p5000

Any advise would be appreciated.


#2

It looks like it is not being deinterlaced properly. Do you know how/if you are deinterlacing the 1080i sample?


#3

Your correct thought I had checked that, I’m using OBS to capture with a Magewell - USB Capture SDI Gen 2.

I had set OBS to deinterlace but it appears that the capture card does it for me, which is set to blend top and bottom field, setting deinterlace to either top field only or bottom field only doesn’t show the issue, but surly using that would mean I’m missing half the frames?

If I capture directly from CasparCG as ProRes and play back in VLC with deinterlace turned on and set to blend I see the same as what I get with the capture card set to blend.


#4

Blend is not a very high quality deinterlace method. It is likely offered as it is computationally cheap compared others. If you were to try the yadif method in vlc, I expect it would look correct.

but surly using that would mean I’m missing half the frames

Yes, that is correct.

It looks like you will need to do the deinterlacing in obs (with the yadif algorithm) instead of on the card. I know that some others here will be disappointed to know that the deinterlacing on Magewell cards is not very good.


#5

Thanks, in the case of the Magewell - USB Capture SDI Gen 2 you can’t disable deinterlace as it delivers it as progressive.

Tried my Decimator MD-DUCC to convert to 1080p5000 but that didn’t do any better of a job.

Capture from file recorder in CasparCG playing back in VLC using yadif does look much better. https://www.dropbox.com/s/kzhjq577epzhmmp/CasparCG_libx264_1080i5000.mov?dl=0

Does the file recorder option in CasparCG always record at 25fps, vlc always shows it as 25fps?


#6

Generally, it records in the channel size and rate. Keep in mind that 50 interlaced fields are only 25 full frames, that’s why it might say 25 fps.


#7

If deinterlacing in obs/vlc you will wnat to set the magewell to ‘weave’ mode as that is deinterlacing disabled. When passing around interlaced video, it typically gets done in pairs of fields (which is why vlc reports it as 25fps) like that weave method describes. It is then just some metadata saying that it is interlaced.


#8

Is this what you would expect using weave on the Magewell and yadif and 25fps in OBS?


#9

I suggest you test taking the CCG input into OBS via NDI. You could even route the channel to a separate channel in 1080p50 that is only delivered over NDI to OBS.


#10

My output will be coming from an ATEM not CasparCG so that will not work, I’m taking it direct from CasparCG at the moment for testing.


#11

Yes I think so.
It should look the same as playing the original/caspar recorded clip in vlc with yadif, which that appeared to do for me.