Interlaced to progressive conversion

Hi all,

I’m using Caspar with Redcast as an automated playout in my broadcast station.
Caspar is handling the playout for a weekly show that we’re streaming to facebook.
The Decklink input from our regular playout server is 1080i50. Redcast/Caspar is playing some stream only clips before and after the live input. Behind the Decklink output I’ve got a BM WebPresenter HD as my encoder. The stream to facebook needs to be 1080p25 and we are not so happy with the conversion inside the WebPreseter.
When I set the channel video-mode to 1080p2500 the screen is black, but audio is playing.

Is there a way in Caspar to do the conversion?

kind regards

You can set the CasparCG video format to 1080P2500 and still use the Decklink input set to 1080i5000
So when you need the Decklink input use this command

Don’t set anything in config bij consumer section.
You have an option to let CasparCG auto deinterlace in the config

Use version CasparCG 2.1
You can stream with CasparCG too,
try this
create stream to internet (720p)
ADD 1 STREAM udp://<client_ip_address>:9250 -format mpegts -vcodec libx264 -crf 32 -tune zerolatency -preset ultrafast -vf scale=1280:720
remove -vf scale=1280:720 for HD
quality is set with crf32 lower is better, crf21 looks realy nice

stop the stream
REMOVE 1 STREAM udp://<client_ip_address>:9250

1 Like
Privacy Policy   Terms of Service