How to run YUV file on CasparCG?

ffplay "akiyo_cif.yuv" -f rawvideo -video_size 352x288

I can run the file using the above command on ffmpeg but when I use CCG, I get the following error

[2021-07-19 12:23:59.492] [error]   [ffmpeg] [IMGUTILS @ 0000006E9A0FF190] Picture size 0x0 is invalid

I used this to try to play it

PLAY 1-1 "akiyo_cif.yuv" -c:v rawvideo -s:v 352x288 -preset slow -s 352x288

Have you tried without giving the videosize?

yes, same error.
I used no params as well and it didnt work

PLAY 1-1 "akiyo_cif.yuv"

I am using a test file from here

Please note:

Using ffmpeg.exe gives the same error

Using ffplay.exe works fine

The file you are trying to play only contains the samples for the video pels. There is no informational metadata such as colour space, picture width, picture height, frame rate, interlace properties, which is first display field if interlaced etc.

I suspect that the producer is looking to the file to get the metadata to do the play operation, does not find any and hence returns the error you found.

There is sometimes a metadata file stored with the .yuv video samples file that other programs use to extract the frames at the correct size and speed.