How to playout a webm-file with alpha?

Hi
Are there any way that you can play out a webm-file with alpha in CasparCG?
With the play-command CasparCG plays out the file but it doesnt recognize the alpha-channel.
As a test example-file I have used Geerts start_1080.webm from his HTML-template tutorial, that is a file that I know has alpha when it is inside a HTML-template.

I don’t think it has alpha channel:

If it did, it would say yuva420p AFAIK.

D-mo

Hi Markus

I do it a lot, but as you say in HTML. I have tried to do it just as an mediafile with amcp and get the same result as you. I have files that I know for sure is webm with alpha if need to try. (I made them my self).
I use webM with alpha frequently in Mello for example.

/Olle

Hi D-Mo
But the problem is that the file is done in AE with with VP8 and in the settings the “Include Alpha channel” ticked.


and the result in a HTML-template

The most strange thing was that when I tried to play out the webm-file with the HTML producer it didnt use the alpha channel either.

Hyvää päivää!

Render straight (for best result) alpha from ex. Aftereffects and than i usally use ffmpeg to conform to webm

Without audio:

ffmpeg -i Blaffa_1.mov -c:v libvpx-vp9 -b:v 6M -pix_fmt yuva420p -auto-alt-ref 0 Blaffa_1.webm

With audio:

ffmpeg -i Blaffa_1.mov -c:v libvpx-vp9 -b:v 6M -pix_fmt yuva420p -auto-alt-ref 0 -codec:a libvorbis -qscale:a 8 Blaffa_1.webm

There is also a webm codec online, floating around somewhere, that some of the girls/guys here use.
You may have to tweek the ffmpeg to get your desired result.

/olle

I think the problem is somehow related to this:
https://trac.ffmpeg.org/ticket/8344

more here:

Privacy Policy   Terms of Service