Filter Drawtext


I’m trying to get draw text on top of my video, but something seems to be off, CasparCG accepts my command stars playing video, but the text never shows up.

My command line:
PLAY 1-12 “video_file” filter drawtext=fontfile=LiberationSans-Regular.ttf:text=“this_is_text”:x=100:y=100:fontsize=48:fontcolor=white loop

I tested this with ffplay and everything works
ffplay -i video_file.avi -vf drawtext=fontfile=C:\Casparcg\server\font\LiberationSans-Regular.ttf:text=“this_is_text”:x=100:y=100:fontsize=48:fontcolor=white

I noticed some issues with fonts:

  1. LiberationSans-Regular seems to be only one working from \Casparcg\server\font, if I try to use other fonts it gives an error: [Parsed_drawtext_0 @ 000002287B3DB320] Could not load font “roboto-regular.ttf”: cannot open resource
  2. Tried using Arial font from \Windows\Fonts, same error
  3. Moved Arial font to \Casparcg\server\font, same error

Server version dc2e94b Beta 2

If you guys have a suggestion I’ll be happy to try it out.

I usually do a template to get some text output in CasparCG, what a funny idea to do that in FFMPEG…

For me it seems more efficient way, you need less tools, just one command line. Also you would be able to add live string.

That’s what this template thing is all about, to add dynamic, live text. That was the basic idea behind CasparCG. That is also why it has that “CG” in the end of the name. That means Character Generator and denotes a device that does live graphics in TV broadcasting.

No serious: It will probably not work that way.

Let’s not go off topic, I’m just pointing out that one of the filter commands isn’t working or it’s disabled.

  1. If its broken, nothing wrong to point it out and it should be fixed.
  2. If it’s disabled then getting information about why it’s disabled, be useful for the community.

I’m not looking for a solution, I have working templates.

Ok, then please report this at GitHub, as the devs are not hanging in the forum too much.

This is definetely not a workflow we support currently, and I don’t see us actively supporting this anytime soon. If you’re lucky it might work in 2.2 since that version has an upgraded ffmpeg producer. (Download 2.2 from

Since you are using 2.1 currently, you could also use the built-in text producer. For info about that just write “help producer text producer” into the commandline.


in the latest 2.2 build ( under server/master) you definitely can do this and it works nice.
i have placed the Hack fonts ( in caspars fontdirectory, after that run this command with your file.
PLAY 1-10 valvaka vf “drawtext=fontfile=c\\\\:/caspar/_FONT/Hack-Regular.ttf: text=‘pts\\:%{pts \\: hms} frame\\:%{n} type\\:%{pict_type}’: x=40: y=280: fontsize=60: fontcolor=white: shadowx=2: shadowy=2: alpha=0.7”

Questions like this can also be asked in the help repo at github where it will catch the eyes from the developers who tend to hang over there.