Failed to connect to media-scanner


#1

I’ve got this error whenever a client is trying to connect to the server.
I’ve tried to change the media location but it didn’t help.
Latest versions of server and client.
Thanks


#2

That is in 2.2 beta, right? Just start the scanner.exe in the same folder as the CasparCG server.


#3

Hi, I am executing the scanner.exe but give a error in a console windows.
Error: getaddrinfo ENOENT localhost:8000


#4

Try changing you csaparcg.config file from:

    <amcp>
        <media-server>
            <host>localhost</host>
            <port>8000</port>
        </media-server>
    </amcp>

to

    <amcp>
        <media-server>
            <host>127.0.0.1</host>
            <port>8000</port>
        </media-server>
    </amcp>

#5

Thanks, but I still have the same error…


#6

You have something else running on port 8000?


#7

I’d like to jump in on this, because maybe you guys can help me.

I’m also running CG Server 2.2 and would like to use it with the Just Macros software. This used to work perfectly fine with CG Server 2.0.7, but I wanted to update cause of some new functionalities in the 2.2 version.

The issue that I have right now, is that my JustMacros apparently isn’t able to find the templates anymore and therefore I always get an “Template not found…” error. Scanner is running and using the CG Client I can also play the templates.
I see that this is more of a JustMacros issues than a CasparCG issue, but I was hoping that somebody might be able to help me.

Thanks,
Tobi