Duo2 and input


#1

Hi
Im trying to do the following (server 2.2.0)
channel 1 Key+fill
Channel 2 Fill
and tries without success input a SDI-signal to Channel2
I have a Decklink duo2 in Desktop setup connectors configurated as first/SD1, second/SDI3&4, third/SDI2 and forth/NONE
if I name the connectors in the following order “ref-1-3-2-4” then I get CasparCG channel1 as Key&Fill from connectors 2&4 and channel2 from connector3.
But when I add to the client a Decklink Input from Device 1 it just gives out black (device 2 the same) and I know I have the right input resolution.

My config file

<channels>
 <channel>
    <video-mode>1080i5000</video-mode>
    <straight-alpha-output>true</straight-alpha-output>
    <channel-layout>stereo</channel-layout>
      <consumers>
        <decklink>
          <device>2</device>
            <embedded-audio>true</embedded-audio>
            <channel-layout>stereo</channel-layout>
            <latency>low</latency>
            <keyer>external</keyer>
            <key-only>false</key-only>
            <buffer-depth>3</buffer-depth>
            <custom-allocator>true</custom-allocator>
        </decklink>
      </consumers>
  </channel>
<channel>
  <video-mode>1080i5000</video-mode>
 <straight-alpha-output>true</straight-alpha-output>
    <channel-layout>stereo</channel-layout><consumers>
    <decklink>
      <device>3</device>
      <embedded-audio>true</embedded-audio>
           <channel-layout>stereo</channel-layout>
            <latency>low</latency>
            <keyer>external</keyer>
            <key-only>false</key-only>
            <buffer-depth>3</buffer-depth>
            <custom-allocator>true</custom-allocator>
    </decklink>
  </consumers>
</channel>
  </channels>

any ideas why I f´dont get any input
This used to work with server2.0.7
br markus


#2

On my Duo2 it’s (bottom up) ref, 2, 1, 4, 3. When I do the same I have the fill key on 1+2 and the fill only on the 3. Then the Decklink input refers to device 4 So the DECKLINK PLAY command uses “4” as a parameter.
The fill key is device 1 and the fill only device 2. At least that is how it works on 2.0.7 as I don’t use 2.2, because I think it’s not a good version without all the INFO commands etc.

		<channel>
			<video-mode>1080i5000</video-mode>
			<straight-alpha-output>false</straight-alpha-output>
			<consumers>
				<decklink>
					<device>1</device>
					<embedded-audio>true</embedded-audio>
					<channel-layout>stereo</channel-layout>
					<latency>normal</latency>
					<keyer>external</keyer>
					<key-only>false</key-only>
					<buffer-depth>3</buffer-depth>
					<custom-allocator>true</custom-allocator>
				</decklink>            
			</consumers>
		</channel>
		<channel>
			<video-mode>1080i5000</video-mode>
			<straight-alpha-output>false</straight-alpha-output>
			<consumers>
				<decklink>
					<device>2</device>
					<embedded-audio>true</embedded-audio>
					<channel-layout>stereo</channel-layout>
					<latency>normal</latency>
					<keyer>default</keyer>
					<key-only>false</key-only>
					<buffer-depth>3</buffer-depth>
					<custom-allocator>true</custom-allocator>
				</decklink>
			</consumers>
		</channel>

#3

Thanks now I did get it to work
CH1 Key+Fill
CH2 Fill
Input Device 1

Config in Desktop Video Setup (channel here Decklink channels NOT CASPARCG)
first channel connectors SDI 1
second channel connectors SDI 3 & SDI 4
third channel connectors SDI 2
forth channel connectors None

in casparcg.config
first channel decklink device 2 (external keyer)
second channel device 3 (key only = false)

then
the cabeling from caspar would be the following form left to right
(now I talk CasparCG Channels, NOT DECKLINK)

  • ref
  • SDI IN (device 1 in client)
  • Channel 2 Fill Out
  • Channel 1 Key Out
  • Channel 1 Fill Out

thanks Markus