<device> not changing the output screen

I’m trying to get the CasparCG server to output to an HDMI monitor which is connected to the CasparCG server machine. I have tried changing the number in the <device> tag but the output is always shown fullscreen on my laptop screen and not the external monitor. Here is the relevant part of my config

    <channel>
        <video-mode>720p5000</video-mode>
        <consumers>
            <screen>
				<device>1</device>
				<windowed>false</windowed>
				<sbs-key>true</sbs-key>
			</screen>
            <system-audio />
        </consumers>
    </channel>

Is my logic flawed? Can anyone point out the mistake I’m making?

I am not sure, if the device starts fron 0 or from 1. Have you tried setting it to 2?

Thanks for your response. I’ve tries 0, 1 and 2 and none of them give me the result I’m looking for.
Is the information in this link still up-to-date? Seems like a few of the tags it’s suggesting don’t do what I would expect.
CasparCG config file explained

<device>2</device>

Works in server 2.07 and 2.3
but not not in 2.1 beta2

Thanks for your message. Is there a command I can run to see all the screen that CasparCG can see? I’ve tried 2.0.7 and 2.3 but either are giving me a full screen output on the HDMI monitor.

No command, but a lot more options in the config:

<screen>
	<device>1</device> <!-- [1..] -->
	<aspect-ratio>default</aspect-ratio> <!-- [default|4:3|16:9] -->
	<stretch>fill</stretch> <!-- [none|fill|uniform|uniform_to_fill] -->
	<windowed>true</windowed> <!-- [true|false] -->
	<key-only>false</key-only> <!-- [true|false] -->
	<vsync>false</vsync> <!-- [true|false] -->
	<borderless>false</borderless> <!-- [true|false] -->
	<interactive>true</interactive> <!-- [true|false] -->
	<always-on-top>false</always-on-top> <!-- [true|false] -->
	<x>0</x> <!-- Left coordinate -->
	<y>0</y> <!-- Top coordinate -->
	<width>0</width> <!-- (0=not set) -->
	<height>0</height> <!-- (0=not set) -->
	<sbs-key>false</sbs-key> <!-- side by side key [true|false] -->
	<colour-space>RGB</colour-space> <!-- [RGB|datavideo-full|datavideo-limited] (Enables colour space convertion for DataVideo TC-100 / TC-200) -->
</screen>

If “device” isn´t working for you, you can try it with x and y coordinate.

Thanks, this will be my workaround :blush:

Privacy Policy   Terms of Service